MVM Bots arent spawning even with a pop file

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

guest3444307

L1: Registered
Aug 3, 2017
5
Can I get some Help? I'm trying to make a mvm map and everything seems to be fine, then I load up the map, start the wave and it doesn't spawn anything for the robots side, it detects the pop file but spawns nothing from my knowledge, in the console something called wave_relay_start (or is it wave_start_relay) so that may have something to do with it. can you help me?
 

SnickerPuffs

(*single chuckle*)
aa
Apr 10, 2014
1,231
If you made your mission with mvm.tf, you need to double check to see if all the spawn names match with the spawn entity names.

I had that issue with the a1 version of Helix.
 

Svode

Take a Chance on Me
aa
Jul 31, 2016
166
I don't recommend you use mvm.tf, learning it yourself in Notepad++ will greatly benefit you on your future MvM popfiling endeavors. Also, as far as I know, the site is broken when making their files.

It took a goofus like me a short time to get the hang of it but it worked out greatly. Handling the code at the source instead of using a 3rd party website allows you to have more flexibility and be able to customize more things within your popfile.
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
Or you can be a lazy lil shit like me and use old.mvm.tf like I did, which unlike it's newer brother (mvm.tf), actually produces working popfiles.

If you do though, you should still learn at least basic popfile syntax so that you can diagnose and fix problems by hand, as well as make tweaks and customize things that old.mvm.tf doesn't let you customize.
 

guest3444307

L1: Registered
Aug 3, 2017
5
so How do I fix my problem without having to remake the file again, it wont spawn the bots which is confusing, I would go check the official ones but I don't know where that is.
I don't know how to really fix it so I thought of replacing blu spawn with spawnbot instead to see if it would work, it only removed one of the errors