Missing models.

Discussion in 'Mapping Questions & Discussion' started by grazr, Oct 4, 2009.

  1. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    I opened up my SDK this afternoon to get to work on my cp_axle in the hopes of finishing a release worthy version before my uni workload hits me like.. something that hits really really hard.

    But i can't progress because certain models have just vanished from the directory.

    Models that include: models/props_forest/cliff_wall_09a.mdl
    and all subsequent versions that end with a letter, and additionally models/props_forest/cliff_wall_10.mdl.
    As well as the waterfall rock: models/props_forest/rock_waterfall.mdl
    small rocks: models/props_forest/rock006.mdl
    and several versions of the wooden bridges: models/props_forest/sawmill_bridge.mdl

    I've refreshed my SDK content to no avail and these models merely show as the error model.

    A couple people in steam chat have admitted to no problems on their end. Any one have any idea's or the same problem? Cause this is so frustrating, i'm so close to finishing the next alpha.
     
  2. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    Maybe they put them under another directory? Have you used the model viewer search already?
     
  3. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Can you see these in game?
     
  4. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    I'm not sure why they would seperate the 'rockwaterfall' from the waterfall itself, between two different directories. Nor why they would split half the alpine rocks to another directory, when they were all produced for the same original map.

    All search results fail, and the stand alone model viewer shows no existing models with these names in said directory.


    edit: Yea, these are missing ingame too..
     
    Last edited: Oct 4, 2009
  5. Eradicatus

    Eradicatus L1: Registered

    Messages:
    30
    Positive Ratings:
    7
    All Valve assets are in the GCF files. You must have corrupted them somehow. I suggest re-downloading TF2.
    Or at least refresh or verify cache integrity or whatever it's called.
     
  6. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    Done both of these already, nothing helped.

    I really would not like to re-download TF2 for the sakes of 5 missing models. But if it comes to it i guess i have no choice. Google shows up nothing on the topic.
     
  7. Eradicatus

    Eradicatus L1: Registered

    Messages:
    30
    Positive Ratings:
    7
    You could use GCFScape to check the caches to see if they really are missing or not.
     
  8. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    I guess i could, just to double check; although that's pretty much what the stand alone model viewer did for me. The files were simply not there (if it was a corruption issue, surely the viewer would still see the format of the file and recognise it as a legitimit file type in the explorer window, but just be unable to show me the contents when loading it up).

    /goes to check gcf.
     
  9. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,466
    Delete your tf folder then launch the game. That's basically launching the game as if it's just been installed. It might fix it.
     
  10. Eradicatus

    Eradicatus L1: Registered

    Messages:
    30
    Positive Ratings:
    7
    Mmmm I'm not sure about that.
    The error is in the GCF file which resides in the "steamapps" folder. This file is not in the tf folder at all, so deleting the tf folder, or any tf2 folder will have no effect.

    Grazr, can you post the exact byte size of the "team fortress 2 content.gcf" file?
    If it is missing files, it might show up here as a smaller filesize.
    Mine is 2 970 758 416 byte. (2.76 GB) (actual size, not disk usage size thingy)

    This is a very odd error. I have never come across it before, and I have seen my fair share of oddities regarding Steam and the Source SDK.
     
  11. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    [​IMG]

    Lol.

    Hopefully i can just reset the GCF somehow. Er.... will deleting it and then running TF2 cause an auto download of the missing content?
     
  12. Eradicatus

    Eradicatus L1: Registered

    Messages:
    30
    Positive Ratings:
    7
    Haha that's awesome.
    You simply have to delete the GCF and download the game again.
    (Just starting TF2 after deleting the GCF might work, I have never tried)
    Hopefully you can keep the materials GCF so you don't have to download that one again too.
     
  13. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    Yea, i deleted the content gcf and it's now 'updating'. 45 minutes shouldn't be too painful. Then i can carry on with my work.