Locking a control point does not seem to work

Discussion in 'Mapping Questions & Discussion' started by Giovanni, Jul 8, 2015.

  1. Giovanni

    Giovanni L1: Registered

    Messages:
    10
    Positive Ratings:
    2
    I've been trying to create a variation on the KOTH gamemode using multiple cp's of which there's only one enabled at a time. The problem is, whatever I try to do I cant seem to lock any points. I tried using a logic_auto or team_round_timer to send my team_control_points the command setLocked parameters 1 but they all unlock themselves at the beginning of the round. I've also tried to set the Start Locked variable of the team_control_points to Yes, but they still unlock. I'm still a learning mapping, so do I need a entity in the map (next to the team_control_point_master and tf_gamerules and 2 team spawn points) to lock my capture points? Or does the command not work? I've seen more posts on this forum in the past having the setLocked command not work, but haven't found a solution yet. :(
     
  2. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,742
    try SetTeamCanCap <team> <boolean>

    I can never remember what numbers the teams are, I look it up every time. iirc this one uses 2/3 so 2 is red, 3 is blue? Maybe. Don't quote me on that.
     
  3. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,387
    Positive Ratings:
    4,219
    I think SetLocked is broken (it didn't work last time I tried it) so you'll have to resort to other methods.