I Need help from this pop file

(Urso) Jailson Professor

L1: Registered
Jan 28, 2019
3
0
I made a wave 666 in rottenburg based on another map of hellburg that a map of rottenburg that has its halloween version of it I saw the pop file of the map file and decided to try to do in rottenburg and finished so when I start tf2 and I tried the wave in the game did not work I tested it in the MvM.tf site so that you also know that this site does not work so I tried to do in notepad ++ to wave and ended it in the program so when I started the game it gave those errors
KeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, wave, WaveSpawn, Squad, TFBot, WaveSpawn, (*CharacterAttributes*),
KeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, WaveSpawn, WaveSpawn, WaveSpawn, 50, (*Squad*), (*TFBot*), (*CharacterAttributes*),
KeyValues Error: LoadFromBuffer: missing { in file
(*WaveSpawn*), (*Squad*), (*TFBot*), (*ItemAttributes*), (*armor piercing*), (*RevertGateBotsBehavior*), (*CharacterAttributes*), (*override footstep sound set*), (*CharacterAttributes*),
TFBotSpawner: Unknown field 'WaveSpawn'
Warning reading TFBot spawner definition
Unknown attribute 'TFBot' in Squad definition.
Invalid populator 'WaveSpawn'
Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_rottenburg_NIGHTMARE.popKeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, wave, WaveSpawn, Squad, TFBot, WaveSpawn, (*CharacterAttributes*),
KeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, WaveSpawn, WaveSpawn, WaveSpawn, 50, (*Squad*), (*TFBot*), (*CharacterAttributes*),
KeyValues Error: LoadFromBuffer: missing { in file
(*WaveSpawn*), (*Squad*), (*TFBot*), (*ItemAttributes*), (*armor piercing*), (*RevertGateBotsBehavior*), (*CharacterAttributes*), (*override footstep sound set*), (*CharacterAttributes*),
Warning reading TFBot spawner definition
Unknown attribute 'TFBot' in Squad definition.
Invalid populator 'WaveSpawn'
Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_rottenburg_NIGHTMARE.popKeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, wave, WaveSpawn, Squad, TFBot, WaveSpawn, (*CharacterAttributes*),
KeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, WaveSpawn, WaveSpawn, WaveSpawn, 50, (*Squad*), (*TFBot*), (*CharacterAttributes*),
KeyValues Error: LoadFromBuffer: missing { in file
(*WaveSpawn*), (*Squad*), (*TFBot*), (*ItemAttributes*), (*armor piercing*), (*RevertGateBotsBehavior*), (*CharacterAttributes*), (*override footstep sound set*), (*CharacterAttributes*),
TFBotSpawner: Unknown field 'WaveSpawn'
Warning reading TFBot spawner definition
Unknown attribute 'TFBot' in Squad definition.
Invalid populator 'WaveSpawn'
Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_rottenburg_NIGHTMARE.pop
TFBotSpawner: Unknown field 'WaveSpawn'
Warning reading TFBot spawner definition
Unknown attribute 'TFBot' in Squad definition.
Invalid populator 'WaveSpawn'
Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_rottenburg_NIGHTMARE.popKeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, wave, WaveSpawn, Squad, TFBot, WaveSpawn, (*CharacterAttributes*),
KeyValues Error: RecursiveLoadFromBuffer: got } in key in file
Population, WaveSpawn, WaveSpawn, WaveSpawn, 50, (*Squad*), (*TFBot*), (*CharacterAttributes*),
KeyValues Error: LoadFromBuffer: missing { in file
(*WaveSpawn*), (*Squad*), (*TFBot*), (*ItemAttributes*), (*armor piercing*), (*RevertGateBotsBehavior*), (*CharacterAttributes*), (*override footstep sound set*), (*CharacterAttributes*),
TFBotSpawner: Unknown field 'WaveSpawn'
Warning reading TFBot spawner definition
Unknown attribute 'TFBot' in Squad definition.
Invalid populator 'WaveSpawn'
Parse Failed in CPopulationManager::Initialize
if you see this post please help me fix this wave problem I wanted to test it or if you help me edit it I will leave here the link of the wave that is with problem if you give me a reply and then I'll see Friday that I'm too busy
 

Attachments

  • mvm_rottenburg_NIGHTMARE.pop
    87.4 KB · Views: 159
Last edited:

Startacker!

WANT ME TO BE REAL? MAKE ME.
aa
Jun 15, 2013
647
1,197
I went through your popfile and patched some things up, there was a lot going on, so some of these notes might have become incorrect as I was going through it, but I included it if you want to see what went wrong.
  • You generally shouldn't use uppercase letters in your filename, as some servers (such as those on Linux) don't like caps.
  • You're missing a } to close the WaveSpawns at line 498, line 774, and line 936
  • You have an extra } inbetween the Giant Gunner and Profissional Medic at line 1472
  • There is no Where in Rottenburg for spawnbot_stealth, use flankers instead
  • There is also no Where in Rottenburg for spawnbot_red or spawnbot_red_silent
  • There's also an extra } at line 509
  • You have an extra { at line 774
  • Unnecessary WaveSpawn at line 358
  • Unnecessary Where at line 1256
  • Moved the } at line 372 that was splitting your WaveSpawn apart to line 404
  • The Final Boss Dragon Heavy uses gatebot logic, which Rottenburg does not support.
  • Templates are your friend! Try using them sometime
That's as far as I got your popfile to a functional state, there are still issues that I believe relate to the bots themselves and missing icons, which I'll let you take a look at yourself.
 

Attachments

  • mvm_rottenburg_nightmare.pop
    86.6 KB · Views: 152