help with decompiled map

Discussion in 'Mapping Questions & Discussion' started by RAYhill, Aug 15, 2018.

  1. RAYhill

    RAYhill L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    tried to modify ctf_well but noticed that when i started the map alene (wihout any adjustments) this popped up :
    The command failed.Windows reported the error: the system cannot find the file specified. do you want to continue? if i press yes tf2 starts but map wont any help?
     
  2. nesman

    aa nesman master of fast travel

    Messages:
    643
    Positive Ratings:
    534
    compile log? decompiled maps usually have errors when decompiled like areaportals not working anymore, thats just how it works
     
    • Agree Agree x 1
  3. DrSquishy

    aa DrSquishy ???

    Messages:
    1,227
    Positive Ratings:
    802
    If you want to compile a version of cp_well that's decompiled from the BSP, you'll need to fix all of the errors in the compilelog to get it working properly
     
  4. Viemärirotta

    aa Viemärirotta sniffer

    Messages:
    1,003
    Positive Ratings:
    568
    The error means no bsp file came out of vbsp, something got wrong in in the process and bad. Even though the compile failed, it should putout the error in the log.
     
  5. RAYhill

    RAYhill L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    first there was a error with are portals so i deleted them all but there is still a weird leak where the train in the middle is idk... here is the compile log:

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\rd_well.vmf"

    Valve Software - vbsp.exe (Aug 2 2018)
    4 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\rd_well.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Patching WVT material: maps/rd_well/nature/blendgroundtograss001b_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    **** leaked ****
    Entity path_track (-329.46 -34.00 -1407.00) leaked!

    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5120.0 4608.0 0.0)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (6144.0 4608.0 0.0)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5632.0 5120.0 0.0)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5441.8 3072.0 0.0)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5953.8 3072.0 0.0)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5120.0 3584.0 0.0)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (6144.0 3584.0 0.0)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (1024.0 4152.0 -1544.0)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:

    *** Suppressing further FindPortalSide errors.... ***
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (1)
    Find Visible Detail Sides...Bad detail brush side


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -fast "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\rd_well"

    Valve Software - vvis.exe (Aug 2 2018)
    fastvis = true
    4 threads
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\rd_well.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\rd_well.bsp

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -noextra "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\rd_well"

    Valve Software - vrad.exe SSE (Jul 18 2018)

    Valve Radiosity Simulator
    4 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\rd_well.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\rd_well.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\rd_well.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\rd_well.bsp"

    The command failed. Windows reported the error:
    "The system cannot find the file specified."
     
  6. nesman

    aa nesman master of fast travel

    Messages:
    643
    Positive Ratings:
    534
    looks like areaportals are causing it, just hide them in hammer and see if it will allow a compile
     
  7. RAYhill

    RAYhill L1: Registered

    Messages:
    5
    Positive Ratings:
    0
  8. nesman

    aa nesman master of fast travel

    Messages:
    643
    Positive Ratings:
    534
    something you can do is look for a leak using the tab at the top of hammer. map > load point file, then follow the red line it presents and see if there are any holes in the map. another thing you can do is use the selector for groups on the right side of hammer and turn off all areaportals for good to make sure that you did not miss one or something.
     
  9. RAYhill

    RAYhill L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    i stated that above: there is a leak but the leak itself is just a path_track inside train thats supposted to go throught the center. there is no hole there im just confused.. but i have found few meters next to it prop of another train thats sticking out of skybox should i delete it?
     
  10. nesman

    aa nesman master of fast travel

    Messages:
    643
    Positive Ratings:
    534
    yea that would cause a leak OR you could surround the prop thats outside the map in nodraw then its technically inside the map
     
  11. RAYhill

    RAYhill L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    im giving up that map is just a complete mess and as the guy above stated something is missing im gonna look around for repaired well version but for now ill leave it alone thanks for help anyways