Fade distance console command?

Discussion in 'Team Fortress 2 Talk' started by cornontheCoD, Nov 20, 2008.

  1. cornontheCoD

    cornontheCoD L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    70
    ok, so I don't know if it's just me, but I have just been noticing models in L4D fading away slowly as I walk away. My model/textures are on high, so I dont know why its doing this. It doesnt matter what game it is, so what's the console command to change the fade distance?

    the fading away thing is REALLY bugging me
     
  2. Scotland Tom

    Scotland Tom L6: Sharp Member

    Messages:
    332
    Positive Ratings:
    64
    If I'm correct then the model fading is something that's been specified by the map maker. It's a way of optimizing the map for performance. The person making the map sets the lod (level of detail) value for a model that dictates how far away it should be seen. It's not a setting that can be altered in the options menu, it's a hard limit imposed by the map maker and a permanent feature of the map itself.

    Usually the lod values are set well enough so that during gameplay you generally won't notice as your focus will likely be on the zombie hordes rather than the boxes and oil drums down the street you just came from.

    EDIT: I should add that I'm not really sure whether there's a command of some sort that will tell the game to ignore the lod values and just draw everything. There could be. I also reserve the right to be completely wrong about everything I said above. ;)
     
    • Thanks Thanks x 1
    Last edited: Nov 20, 2008
  3. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    86
    Yep, as far as I know, when you place model on the map (as a mapper), you specify the view distance that is coded into the .bsp. A mindful mapper will be wary of poor performance and set the models' view distance to the lowest possible setting.
     
  4. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,920
    Diagnosis: You're playing on a mode too easy
    Prescription: Expert mode for a month
     
  5. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,767
    Turn up your DX level? Fade distances will change depending on your graphics settings. I believe the max settings will be what the mapper designates, but your system can take over this for you; which can be annoying. Maybe turn your visual performance levels up.

    This is true for all Source based games, pl_goldrush is a prime example. Just go through it with no other players and you'll notice loads of models fading in plain sight that you didn't before, because the player is looking where the enemy players would likely ambush/attack from. The same goes for the defenders, on the second stage the track actually fades outside the starting gates quite blatently. Which is surprising considering it's significance (compared to crates and barrels in a dark corner).
     
  6. cornontheCoD

    cornontheCoD L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    70
    lol, actually, it was when I was testing my settings to get film grain and other color effects to work. currently on my settings, none of the color correction/film grain works for me. I have to turn up the settings to get film grain and other color corrections to appear, but then it lags too much. I have it set to full resolution, so I am going to try the recommended settings (lower resolution) today

    and about the dxlevel: how do I change that? I got that response when asking about my film grain problem (which I kinda solved), but I never figured out how to change my dxlevel