1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

AreaPortals

Discussion in 'Mapping Questions & Discussion' started by [FT] Andy, Sep 15, 2008.

  1. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    I've stared work on my first map and i'm currently working on optimization after reading many guides. 2 areas of the map are seperated by a wide doorway and so i have placed an area portal there. However, the other side of the doorway still renders when standing in certain positions:
    working:
    [​IMG]
    not working after taking a few steps back:
    [​IMG]
    [​IMG]
     
  2. Zephyr

    Zephyr L1: Registered

    Messages:
    27
    Positive Ratings:
    2
    Looks perfectly normal to me, it renders the full object if you can see any part of it, don't worry about it, it's working properly and will help it run smoothly even if you don't notice it.
     
  3. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,768
    Possibly, you are rendering the other side from above (through the skybox), a bug in your visleaf set up.

    You also have a very perculiar triangle placement on your textures. It doesn't look like you're using any hint brushes; are you?
     
  4. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    i havent placed any hint brushes as of yet. What should the wireframe look like on the textures?
     
  5. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,768
    Well it's pretty hard to see how you've actually constructed your geometry but it's very messy. Plus a lot of your textures are misalligned.

    Is your skybox just a flat brush over the top of your map or is it like a square bubble?
     
  6. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    here is how i've contrusted the walls
    [​IMG]
    and the skybox
    [​IMG]
     
  7. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,768
    Ah, i see now. here, this is why your areaportal doesn't "seem" to work.

    [​IMG]

    I suggest adding a hint brush across the plane i illustrated in green. It is a good idea to have several at different heights due to people being thrown in the air by explosions etc.

    edit: I updated the image (with better wording). You might want to refresh the page.
     
    • Thanks Thanks x 2
    Last edited: Sep 16, 2008
  8. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    i see, thanks for the help :)
     
  9. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    damn, it hasn't worked, would the ramp cause any problems with the visleafs ?
     
  10. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,768
    it would cut up your leaf nodes more if it was standard brush work. You could tie it to func_detail but for the most part it would only reduce compile time, i believe; and not even by that much.

    Check out the command mat_leafvis 1 and mat_leafvis 3 to view your leafnodes.

    I'm not sure what else to add i'm afraid, other than maybe the area is being rendered through those side corridors, from your main area.

    edit: could you upload the vmf? That way i could take a look for myself at what's happening.

    edit2: Are those areaportal windows in those corridor exits/entrances? if they are, when you walk out into the main area, you will be opening those areaportals (if you are within the fade distance required to deactivate their effects). Effectively opening the other area up despite the closed door.
     
    Last edited: Sep 16, 2008
  11. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    dont't worry too much, i'll see what i can do, i may redesign the doorways and corridors joining the two. Cheers for the advice
     
  12. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    If something is rendering behind the closed areaportal, this means it belongs to ur current area.
     
  13. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    i've got it working, it was due to the side exit on the right, i've re-made that route now with a door/areaportal.
     
  14. MrTwoVideoCards

    MrTwoVideoCards L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    Also an areaportal should always be set to open. An areaportal acts much like a viewcone only rendering whats behind it based on your view against the brush face.
     
  15. [FT] Andy

    [FT] Andy L1: Registered

    Messages:
    38
    Positive Ratings:
    0
    i've set all of them to open except for the ones that are linked with the doors