TF2 stops working after opening my map.

Discussion in 'Mapping Questions & Discussion' started by RataDeOrdenador, Dec 12, 2015.

  1. RataDeOrdenador

    RataDeOrdenador L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    102
    Welp,yeah...

    I've been testing and adding stuff to my map. Ok. Everything went fine.

    Last time I tested it,it was working just as planned. I started adding some paths,fixing some textures,yadiyada.

    Now,whenever I open the game and try that map,well... I can select teams,character... But that's it. It stops working with the freaking sound looping again,and again and again.

    Is it because of,I dunno... Maybe leaks? Fighting skybox-other textures? Don't tell me it's because of my toaster. I would just kill myself. D;

    I don't have any leak and all those "fighting textures" are fixed,so I don't know what might be.

    Also,I'll leave the compile log,if that helps on something. :V

    ** Executing...
    ** Command: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.vmf"

    Valve Software - vbsp.exe (Dec 2 2015)
    2 threads
    materialPath: C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Patching WVT material: maps/pl_canyonfield/dev/dev_blendmeasure_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...
    Merged 98 detail faces...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (0)
    writing C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.prt...Building visibility clusters...
    done (0)
    *** Error: Skybox vtf files for skybox/sky_well_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_well_01 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_well_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_well_01 to build the default cubemap!
    Finding displacement neighbors...
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (0) (331924 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Compacting texture/material tables...
    Reduced 1182 texinfos to 592
    Reduced 37 texdatas to 32 (864 bytes to 760)
    Writing C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.bsp
    3 seconds elapsed

    ** Executing...
    ** Command: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield"

    Valve Software - vvis.exe (Dec 2 2015)
    2 threads
    reading c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.bsp
    reading c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.prt
    352 portalclusters
    874 numportals
    BasePortalVis: 0...1...2...3...4...5...6...7...8...9...10 (0)
    PortalFlow: 0...1...2...3...4...5...6...7...8...9...10 (4)
    Optimized: 184 visible clusters (0.59%)
    Total clusters visible: 31309
    Average clusters visible: 88
    Building PAS...
    Average clusters audible: 285
    visdatasize:28703 compressed from 33792
    writing c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.bsp
    4 seconds elapsed

    ** Executing...
    ** Command: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield"

    Valve Software - vrad.exe SSE (Dec 2 2015)

    Valve Radiosity Simulator
    2 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.bsp
    Setting up ray-trace acceleration structure... Done (0.97 seconds)
    2477 faces
    291350 square feet [41954468.00 square inches]
    0 Displacements
    0 Square Feet [0.00 Square Inches]
    2477 patches before subdivision
    33873 patches after subdivision
    sun extent from map=0.000000
    21 direct lights
    BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (14)
    BuildVisLeafs: 0...1...2...3...4...5...6...7...8...9...10 (9)
    transfers 3505979, max 473
    transfer lists: 26.7 megs
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #1 added RGB(138463, 108565, 106566)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #2 added RGB(24689, 16236, 16818)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #3 added RGB(4647, 2608, 2798)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #4 added RGB(911, 442, 481)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #5 added RGB(182, 78, 86)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #6 added RGB(37, 14, 16)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #7 added RGB(8, 3, 3)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #8 added RGB(2, 1, 1)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #9 added RGB(0, 0, 0)
    Build Patch/Sample Hash Table(s).....Done<0.0168 sec>
    FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (5)
    FinalLightFace Done
    0 of 0 (0% of) surface lights went in leaf ambient cubes.
    ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (4)
    Writing leaf ambient...done
    Ready to Finish

    Object names Objects/Maxobjs Memory / Maxmem Fullness
    ------------ --------------- --------------- --------
    models 31/1024 1488/49152 ( 3.0%)
    brushes 933/8192 11196/98304 (11.4%)
    brushsides 6283/65536 50264/524288 ( 9.6%)
    planes 2840/65536 56800/1310720 ( 4.3%)
    vertexes 4697/65536 56364/786432 ( 7.2%)
    nodes 1120/65536 35840/2097152 ( 1.7%)
    texinfos 592/12288 42624/884736 ( 4.8%)
    texdata 32/2048 1024/65536 ( 1.6%)
    dispinfos 0/0 0/0 ( 0.0%)
    disp_verts 0/0 0/0 ( 0.0%)
    disp_tris 0/0 0/0 ( 0.0%)
    disp_lmsamples 0/0 0/0 ( 0.0%)
    faces 2477/65536 138712/3670016 ( 3.8%)
    hdr faces 0/65536 0/3670016 ( 0.0%)
    origfaces 1815/65536 101640/3670016 ( 2.8%)
    leaves 1152/65536 36864/2097152 ( 1.8%)
    leaffaces 3011/65536 6022/131072 ( 4.6%)
    leafbrushes 1761/65536 3522/131072 ( 2.7%)
    areas 5/256 40/2048 ( 2.0%)
    surfedges 19952/512000 79808/2048000 ( 3.9%)
    edges 12858/256000 51432/1024000 ( 5.0%)
    LDR worldlights 21/8192 1848/720896 ( 0.3%)
    HDR worldlights 0/8192 0/720896 ( 0.0%)
    leafwaterdata 0/32768 0/393216 ( 0.0%)
    waterstrips 328/32768 3280/327680 ( 1.0%)
    waterverts 0/65536 0/786432 ( 0.0%)
    waterindices 6312/65536 12624/131072 ( 9.6%)
    cubemapsamples 0/1024 0/16384 ( 0.0%)
    overlays 0/512 0/180224 ( 0.0%)
    LDR lightdata [variable] 837972/0 ( 0.0%)
    HDR lightdata [variable] 0/0 ( 0.0%)
    visdata [variable] 28703/16777216 ( 0.2%)
    entdata [variable] 47326/393216 (12.0%)
    LDR ambient table 1152/65536 4608/262144 ( 1.8%)
    HDR ambient table 1152/65536 4608/262144 ( 1.8%)
    LDR leaf ambient 3475/65536 97300/1835008 ( 5.3%)
    HDR leaf ambient 1152/65536 32256/1835008 ( 1.8%)
    occluders 0/0 0/0 ( 0.0%)
    occluder polygons 0/0 0/0 ( 0.0%)
    occluder vert ind 0/0 0/0 ( 0.0%)
    detail props [variable] 1/12 ( 8.3%)
    static props [variable] 1/9014 ( 0.0%)
    pakfile [variable] 399/0 ( 0.0%)
    physics [variable] 331924/4194304 ( 7.9%)
    physics terrain [variable] 2/1048576 ( 0.0%)

    Level flags = 0

    Total triangle count: 7712
    Writing c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.bsp
    33 seconds elapsed

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\PL_Canyonfield.bsp" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf\maps\PL_Canyonfield.bsp"
     
  2. MoonFox

    MoonFox L10: Glamorous Member

    Messages:
    737
    Positive Ratings:
    72
    I don't think it has to due with the map exactly, but it appears their is loading bug error.
    if it works while spectating, then the map has a fatal spawning error that causes the game to crash
    if it crashes while spectating, then tf2 is acting up. Refresh the cache, it should resolve this error
     
  3. RataDeOrdenador

    RataDeOrdenador L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    102
    It works while spectating... But it's odd,since I haven't touched anything of the spawn (If that's ACTUALLY the problem)

    Oh well,I'll see what I can do then. Still it's really strange. :V
     
  4. MoonFox

    MoonFox L10: Glamorous Member

    Messages:
    737
    Positive Ratings:
    72
    I hope you get things fixed
     
  5. RataDeOrdenador

    RataDeOrdenador L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    102
    I've added the RED info_player_teamspawn from the "Map start" thing... yeah...

    But same "crash for no reason" (or well,maybe because it has that "fatal spawning error that causes the game to crash")

    I still don't know why,or even when it happend that error. I just kept adding stuff,nothing else. Haven't touched anything that I could say "Oh well,gotta send this map to the trash can and start again. yay". It's seriously pissing me off,because I just don't know what to do. I can just keep working on the map,but it should be pointless since I can't test it properly. D;
     
  6. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,006
    Positive Ratings:
    1,160
    The usual causes of crashes like this are logic errors in your I/O and corrupt game files (usually caused by leaving Hammer open while TF2 updates). You could try hiding all game logic from your map except player spawns and seeing if you still crash - if you don't, then start checking all of your logic; if you do, validate your game.
     
  7. RataDeOrdenador

    RataDeOrdenador L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    102
    Haven't tried a second time,but when I hid all the logic,it worked fine. Again,dunno why would happen something like that. I haven't touched any of the logic. :V

    Oh well,I'm sadly too tired to keep going. So I'll probably try and fix it tomorrow. Anyhow,thank you so much. I was just starting to rage for no reason. ;D
     
  8. Hyperion

    aa Hyperion L16: Grid Member

    Messages:
    810
    Positive Ratings:
    618
    I dont know is it possible but your map name could have something to do with crash. I suggest you to not use capital letter in maps name
     
  9. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Thats just for our servers, and thats because our servers are special.
     
  10. RataDeOrdenador

    RataDeOrdenador L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    102
    And AGAIN,don't know why it started giving me this error,since I haven't touched ANYTHING from it and I've been having this configuration the whole time. damnyouhammer.

    [​IMG]

    I've been hiding all the logics until I found the team_train_watcher is the one giving me problems. It's the same one (with the same cart and the same other logics) from the GameTypeLibrary thingie. Obviously,edited so it matches the names and things I've been using.
     
  11. RataDeOrdenador

    RataDeOrdenador L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    102
    Welp,nevermind... I just made another team_train_watcher and copied some of the settings I had. It works perfect now.

    Close this thread men. We're done here.