Buy Elder Scrolls Online: Greymoor for PC at Green Man Gaming

Rough'n'ready Portal 2 SDK

Discussion in 'Portal 2' started by Randdalf, Apr 20, 2011.

  1. Freyja

    aa Freyja It hurt itself in it's confusion!

    Messages:
    2,922
    Positive Ratings:
    5,328
    We've been able to reverse tractor beams for a long time now. Also, 300 or -300 is the default/what valve uses.

    As for the map crashing. Are you sure it's not something triggering the crash? There could be a trigger misfiring, or anything really.
     
  2. Boom.Headshot

    Boom.Headshot L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    I don't think it's a trigger misfire because
    1: It appears to be completely random
    and 2: it only happens to the player that is not the host of the coop session

    I'm kind of thinking that gel may have something to do with the crashing, but I'm not sure...
     
  3. DaisyCutter

    DaisyCutter L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    SDK Doesn't load decompiled maps

    Hi, Every time i try and load one of P2's original decompiled maps, it just crashes, 33% is where it happens.

    Any ideas what to do?

    I have tried these maps also.
     
  4. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,392
    Positive Ratings:
    5,471
    You need to give it time. Hammer likes to say its not responding even though it is.
     
  5. Luigi Thirty

    Luigi Thirty L2: Junior Member

    Messages:
    65
    Positive Ratings:
    19
    I'm having a weird problem getting the SDK to work. This map compiles and runs fine, but the placeholders for entities in Hammer are error models.

    [​IMG]

    Not sure what I did. The map runs fine though.
     
  6. DaisyCutter

    DaisyCutter L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    No it closes hammer, it is fine on other maps just decompiled portal2 maps, well original ones. I am using BSPSourse 1.1.1

    Any other thoughts?
     
  7. Freyja

    aa Freyja It hurt itself in it's confusion!

    Messages:
    2,922
    Positive Ratings:
    5,328
    you havn't installed your FGD right I think.
     
    • Thanks Thanks x 1
    Last edited: May 4, 2011
  8. DaisyCutter

    DaisyCutter L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Fixed it! :)
    I had both portal2.fdg and alienswarm.fdg in my game Data Files. Deleted alienswarm.fdg and works perfectly.


    Thanks very much.

    Ps. I should have a rough guide for making panels work soon. Can i post a pdf?
     
  9. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,114
    Positive Ratings:
    6,482
    Yes, by all means, go ahead! Nobody's going to refuse something helpful.
     
  10. Luigi Thirty

    Luigi Thirty L2: Junior Member

    Messages:
    65
    Positive Ratings:
    19
    I'm messing around with the SDK. I've got a map that works fine, but when it loads it plays a sound effect of Dr. Kleiner saying "Oh fiddlesticks, what now" leading me to believe something's broken. That happen to anyone else yet?
     
  11. WastedMeerkat

    WastedMeerkat L3: Member

    Messages:
    144
    Positive Ratings:
    142
    I've never heard of that happening. That's pretty weird...
     
  12. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,392
    Positive Ratings:
    5,471
    Yea, I've never seen entities go "error" like that, usually its just a checkerboard black and pink for me...

    Have you tried re-putting the portal 2 .fgd (or whatever the file type is) back into the folder that the guide suggests?
     
  13. Luigi Thirty

    Luigi Thirty L2: Junior Member

    Messages:
    65
    Positive Ratings:
    19
    I fixed that, I had followed a different guide that skipped copying the editor models into the Portal 2 folder. It still does the Kleiner thing though.
     
  14. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,392
    Positive Ratings:
    5,471
    If it plays a sound when you loud in then you have an entity in it that shouldn't be there... thats the only thing I can think of.

    You are running this through Alien Swarm SDK? The Dr. Kleiner sound effects should've even be anywhere near your SDK unless you've really messed something up.
     
  15. Brits

    Brits L1: Registered

    Messages:
    16
    Positive Ratings:
    3
    In the map I'm working on, the player needs Conversion gel to put a portal on the right place. Water can wash the paint off the wall (to force the player doing something..). If there is already a portal on the gel, water washes off the gel, but the portal stays on the non-portalable wall.

    Is there any entity, which can remove that portal?
     
  16. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,114
    Positive Ratings:
    6,482
    Play with Trigger_portal_cleanser, portal_bumper and func_block portals or something. Or try disabling the brush its on and replacing it with another.
     
    • Thanks Thanks x 1
  17. Phil42

    Phil42 L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Is there a good tutorial for logic gates with branches, such as AND Gates or OR Gates and these. Woulds be very helpful...
     
  18. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,114
    Positive Ratings:
    6,482
    I'll breifly explain it: if you want multiple X's to activate a Y, use logic_branch. setup a logic_branch for each X, and get the X to set it to 0 when its not activated, and 1 when it is. Then link all the branches to a logic_branch_listener, which has OnAllFalse (for when all of them are 0), OnAllTrue (for when all are zero) and OnMixed, for some 1s and some 0s.

    math_counter can be used too. I prefer logic_branches for the picture of the ear.
     
  19. Phil42

    Phil42 L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Hmm it doesnt' work for me...
    I linked the X's to the logic_branchs with this Outputs...
    [​IMG]

    But then I don't know how to link the logic_branchs to the logic_branch_listener.
    I just made it like this, maybe that's the problem...
    [​IMG]

    And then I tried to link the logic_branch_listener to the door like this, is that correct?
    [​IMG]


    So, where's the mistake? Thx Swordfish for your explanation btw =)
     
  20. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,114
    Positive Ratings:
    6,482
    The outputs are sending it to branch1, but its named branch. is that it? I cant see any other problem.
     
Buy Elder Scrolls Online: Greymoor for PC at Green Man Gaming