Problem running map

Discussion in 'Mapping Questions & Discussion' started by zenarium, Jul 12, 2012.

  1. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    I am trying to make my first map.

    I created a simple map to do some tests with a skybox, floor and spawn point only.

    The problem is when I try to run it... The tf2 menu appears but nothing else happens. I wait a lot of time and nothing happens.

    I runned maps in the past, simple maps, in another pc and I could do it. Now I have a much better pc and I can't :S Hardware isn't the problem.
     
  2. Pocket

    aa Pocket func_croc

    Messages:
    4,477
    Positive Ratings:
    2,204
    Just run the map with "Do not launch the game" checked, start TF2 manually, and grab the map from the Create Server menu (the big plus sign).
     
  3. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    Still don't work :S

    It works fine with some maps but ot with this map I created. It also worked with another map that I created in the past, a simple one, like this one.

    Maybe it is the skybox texture... I selected one from this website: https://developer.valvesoftware.com/wiki/Sky_List
     
  4. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,102
    Positive Ratings:
    5,982
    Check your compile log in the Interlopers log checker.
     
  5. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    I removed the texture of the skybox and it still don't work,


    "Check your compile log in the Interlopers log checker." --> What do I should check there?
     
  6. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,102
    Positive Ratings:
    5,982
  7. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    I created another map and I can run it. But in this new map everything is grey... I don't understand this new bug :S
     
  8. Pocket

    aa Pocket func_croc

    Messages:
    4,477
    Positive Ratings:
    2,204
    Your skybox needs to be the tools/toolsskybox texture, not the actual picture of the skybox you want to use. That needs to be set in the map properties, with the "up/dn/lf/rt" part removed.
     
  9. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    I selected the 6 walls of the skybox and selected the texture skybox 3d.

    And than I changed the skybox in skybox properties, in the map menu.

    Isn't this what you tell me to do?

    I am still a noob in source sdk and in making maps :S But I really want to learn how to do it.
     
  10. Micnax

    aa Micnax I maek map

    Messages:
    2,018
    Positive Ratings:
    1,338
    Yup, I believe that's what you should do. Make sure that the whole brush is a skybox texture though rather than just the face that you see.

    And we all start somewhere! You'll get to grips with it soon enough :D
     
  11. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    " Make sure that the whole brush is a skybox texture" --> How do I check that?

    I selected the 6 walls and than I selected the skybox 3d from textures menu and applied it to the 6 walls.
     
  12. Micnax

    aa Micnax I maek map

    Messages:
    2,018
    Positive Ratings:
    1,338
    That sounds right then, don't worry :)
     
  13. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    But it as a bug -.-

    Eveything is grey(two types of grey) when I play in my map...

    I only have a skybox and a floor with a grass texture. When I run the map(it works now) the skybox is grey and the floor is grey to. I Can't distinguish the floor and the skybox, everything as the same color.
     
  14. Micnax

    aa Micnax I maek map

    Messages:
    2,018
    Positive Ratings:
    1,338
    Can you take some screenshots of it?
     
  15. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    Sorry for the delay.

    Here is a screenshot: http://img850.imageshack.us/img850/1525/190720122001.jpg

    I had to take a photo of my screen because when I took a printscreen the entire picture was black.

    I can send you the map if you want. Just give me your e-mail and I send it.

    I really aprreciate your help, I hope we can solve this problem.
     
  16. Micnax

    aa Micnax I maek map

    Messages:
    2,018
    Positive Ratings:
    1,338
    Wow that's really strange... and yeah, try sending it over here and I'll see if it runs on my PC. Might be a graphical error on your end.
    E-mail: joodude@neostuff.info
     
  17. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    I sent it. Did you receive it?
     
  18. Micnax

    aa Micnax I maek map

    Messages:
    2,018
    Positive Ratings:
    1,338
    Yup, sorry I was at an expo all day today. I'll look over it tonight ;D
     
  19. Micnax

    aa Micnax I maek map

    Messages:
    2,018
    Positive Ratings:
    1,338
    Okay, I had a look over at your map and found a few problems that will hopefully help you solve.

    1. Your map filename has a space in it
    This is quite an overlooked but important error! Sometimes a gap in the filename will not let you load the map and will crash most servers, so make sure you replace spaces with an underscore: _
    eg. testes 123.vmf should be testes_123.vmf

    2. You're using an incorrect, or invalid skybox image
    When I went into your map, I came into a world of the void! Oh noes!

    [​IMG]

    This is usually because you're specifying a custom skybox to be used in the Map Properties panel, and since I don't have it, I'm looking straight into the void. On your end, it may look like you have a skybox, but judging from your picture it's corrupted or done quite badly. I'd suggest using one of the official ones from this list: https://developer.valvesoftware.com/wiki/Team_Fortress_2_Sky_List

    Here's how you apply, say, sky_tf2_04 from 2fort:

    [​IMG]

    Now after recompiling your map, lets take a look if it's fixed:

    [​IMG]

    Much nicer! There are plenty to choose from too, so find one that you like~

    I hope that helped!
     
  20. zenarium

    zenarium L2: Junior Member

    Messages:
    82
    Positive Ratings:
    2
    Thank you!!!

    I wanna create a map in the out space. Because tf2 don't have a map in the out space I will have to create my own skybox.

    Thank you for your help!