No lights after hdr compile :-(

Discussion in 'Mapping Questions & Discussion' started by TheDarkerSideofYourShadow, Apr 20, 2009.

  1. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    144
    So I tried to compile my map last night with hdr , final, and nice shadows. However, I realized after having built cubemaps that all my lights in the level were gone. They showed up just fine during a Normal compile, but not the extremely time consuming one.

    Heres what I did.
    Under the expert compile options, I copied HDR Full - final compile (slow!). I then changed the parameters for the lights_exe command to "-both -final -staticproppolys -staticproplighting -textureshadows -game $gamedir $path\$file". The first time I had tried to compile, I had added a new command with almost the same parameter, just -final came right before -game, and moved it up appropriately. However, that time vrad didn't run at all. So I was very happy to see this one work, until of course it didn't.

    So if you know why I've got no light and would be kind enough to explain it to me, that would be greatly appreciated.
     
  2. Icarus

    aa Icarus

    Messages:
    2,246
    Positive Ratings:
    1,182
    I had this problem too.

    Do you have many texlights? Are you getting light bounces of (-1 -1 -1)?

    You probably have reached a 'limit' of sorts on the number of lights you can have in a certain PVS.

    TOO MANY LIGHTS. TEXLIGHTS COUNT AS MANY LIGHTS IN ONE.
     
  3. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,742
    At very least you need some alpha textures defigned in a custom .rad file for -textureshadows to have any kind of an effect, its not doing anything otherwise.

    It could be something to do with your light entities themselves, if the brightnessHDR value isn't -1 -1 -1 (or a sensible light value like 200) you're not going to get any light from them when compiling with HDR. However they default to -1 -1 -1 so I doubt thats the issue.
    Another thing to try is to use "-LDR -HDR" in place of "-both" if you're using the beta SDK