Long Compile... Please Help

Discussion in 'Mapping Questions & Discussion' started by XEnderFaceX, Jul 29, 2017.

  1. XEnderFaceX

    XEnderFaceX L3: Member

    Messages:
    128
    Positive Ratings:
    24
    Hey Mappers, Im Creating a TF2 Map based on the End Of the Line SFM Video, the Map Layout is half done and for some reason the Compile Time already takes a very long time, my latest compile took 3 Hours.
    What can i do?

    i func_detailed alot of Brushes, it should help but it doesnt seem to help

    Please help Hammer Picture (cp_snowgrass).JPG
     
  2. Gangstahwezel

    Gangstahwezel L1: Registered

    Messages:
    33
    Positive Ratings:
    20
    Going from that image of your viewports, you haven't sealed your map. which is quite a critical thing to do and will cause your map to not compile propperly if not sealed.

    You should read this as to why maps need to be sealed in source:
    https://developer.valvesoftware.com/wiki/Seal
     
    • Agree Agree x 2
  3. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    Oh boy, you aren't func_detailing the right things. Large brushes you made the layout with shouldn't be func_detail and you should make these brushes on a higher grid size... because it looks like that you made almost every brush on a tiny grid size which is terrible and will only cause issues in the future.

    I'd say you should rebuild all buildings with a proper grid size.
     
    • Agree Agree x 1
    Last edited: Jul 29, 2017
  4. iiboharz

    aa iiboharz Meme Queen

    Messages:
    707
    Positive Ratings:
    1,030
    I'm gonna have to agree with those two. Learn a bit more about the editor and the engine, how to work on the grid and what func_detailing actually does/is for, before trying a project of this scale.
     
  5. XEnderFaceX

    XEnderFaceX L3: Member

    Messages:
    128
    Positive Ratings:
    24
    Ok thanks for the help
     
  6. XEnderFaceX

    XEnderFaceX L3: Member

    Messages:
    128
    Positive Ratings:
    24
    I turned off the skybox in the visgroup while working on the Map, i activate it before Compiling
     
Tags: