light_spot doesn't show up.

Tappy_

L1: Registered
Aug 3, 2016
29
7
Whenever I compile my map all of my light_spot entities don't show up. They're actually casting light because when I stand underneath the light source my viewmodels get a lot brighter, but I cant actually see the light on any models or brushes.
 

Jusa

aa
May 28, 2013
378
618
1. Check if you have leaks in your map
2. Check that you have a brightness value on the lights: ( xxx xxx xxx XXX ) the first three parts of digits are the color of the light, and the last value is the brightness, light spot entities sometimes require a hight brigthness value.

You could also provide us with screenshots of the lights settings in hammer with ingame screenshots to compare.
 

Tappy_

L1: Registered
Aug 3, 2016
29
7
Everything seems to be fine, here's some screenshots.
 

Attachments

  • 20160915153407_1.jpg
    20160915153407_1.jpg
    77.9 KB · Views: 126
  • 20160915153420_1.jpg
    20160915153420_1.jpg
    104.9 KB · Views: 117
  • Light settings.PNG
    Light settings.PNG
    23.5 KB · Views: 109

seth

aa
May 31, 2013
1,019
851
Light_spots do not look like they're casting light. It's the same as the default light entity. Light_spots are commonly paired with a point_spotlight to create the actual light effect.

Light_spot casts light.
Point_spotlight creates the effect.
 

killohurtz

Distinction in Applied Carving
aa
Feb 22, 2014
1,016
1,277
But the issue here is that the light_spot isn't even casting light on the brush underneath it. I think @Void had this problem recently, but I didn't catch how he fixed it, so perhaps he can shed some light on the situation
 

Tappy_

L1: Registered
Aug 3, 2016
29
7
I just deleted the prop and it seems to shine now, so I'm guessing the problem was that it was inside the prop
 

Pocket

Half a Lambert is better than one.
aa
Nov 14, 2009
4,697
2,581
Weird that the light shone through to your viewmodel, but yeah, that's a common problem. The trick is to not treat the dummy model of a stage spotlight literally; the origin point for the light is actually at the very back of the can, so make sure you don't stick it inside anything.
 

Void

Local Man Unable To Map, Sources Say
aa
Sep 14, 2008
1,870
2,977
You need to do a full lighting compile. Static prop poly lighting, especially. This will solve it.
 

Tumby

aa
May 12, 2013
1,087
1,195
With default settings, light collides with the collision mesh of a model. If the light entity is inside any of the collision boxes, it will not cast light to lightmaps. Default settings also means that every model is lit from their origin point, making this looks rather strange.
Enabling advanced light settings will cause light to collide only with the polygons of the actual model. This also causes light to only collide with the front of each poly and shine through if it hits the back. So you can place a light entity inside of a model and the light will shine through.
Static props also allow for tighter control with lighting when vertex lighting is enabled in the compiler. For example, a vertex is lit from the front by default but can be set to recieve lighting from the front and back. A prop will block light in a way that it can throw a shadow on itself, but this can be disabled if the vertices are placed strangely and cause problems.

http://www.nodraw.net/2010/12/lighting-compile-options/
 

Pocket

Half a Lambert is better than one.
aa
Nov 14, 2009
4,697
2,581
Collision meshes on light fixtures are pretty tight though, so unless you're trying to make the light originate inside the cage, or whatever the term is for that thing, it shouldn't matter; just move the entity just outside of it and no one will know the difference.