Custom model not appearing in map

Discussion in 'Mapping Questions & Discussion' started by eerieone, Oct 10, 2008.

  1. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    I followed Hawk´s Tutorial (http://forums.tf2maps.net/showthread.php?t=838&page=2) step by step, i got my textures right, the model appears correctly in the modelviewer, collisionbox etc....

    ... but as soon as i compile the map, i cant see my custom model.

    edit:
    fooled around a little bit, these are the results:


    prop_static:
    Error! prop_static using model "models/custom/bankvault.mdl", which must be used on a dynamic entity (i.e. prop_physics). Deleted.
    Error loading studio model "models/custom/bankvault.mdl"!

    prop_dynamic:
    bankvault-model is invisible

    prop_physics:
    visible, but affected by gravity, ergo falling to the ground


    has anyone a solution for that? i need it to be static
     
  2. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    144
    Can you post your .qc file for your model? Sounds like you missed a line in there, but it'd be nice to have a look at it just to be certain.
     
  3. Altaco

    Altaco L7: Fancy Member

    Messages:
    485
    Positive Ratings:
    121
    Did you add the $staticprop line to your .qc file when you compiled your model?

    If that doesn't work, try prop_dynamic or prop_static with motion disabled.

    EDIT: Goddamnit shadow, ninja'd.
     
  4. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    my bankvault.qc:



    $modelname custom/bankvault.mdl

    $cdmaterials bankvault/

    $staticprop

    $scale 1.0

    $body studio "bankvault.smd"

    $sequence idle "bankvault.smd" fps 15

    $collisionmodel "bankvault_collision.smd"
    {
    $concave
    }
    my bankvault.qc


    $keyvalues
    {
    "prop_data"
    {
    "base" "metal.small"
    }
    }
     
  5. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    made it a prop_dynamic_override, fadescale at 0

    it sits now where it should be, thx so far lads :)
     
  6. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    got it working nicely

    [​IMG]

    as soon as the model is perfect and nicely skinned, i will make it available in the download-section