Crazy map error

Discussion in 'Mapping Questions & Discussion' started by Revocare, Jan 17, 2011.

  1. Revocare

    Revocare L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    For a while my map had'nt been working when loading it. I went back and fixed a few things, but it finally went through when removing the skybox and using the hollowed skybox method that worked before.

    To my dismay:
    [​IMG]
    [​IMG]

    Is this a simple fix? What's strange is the rendered nodraw. I checked my map, and there are no problems, save for no player start.

    Help would be greatly appreciated.
     
  2. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,629
    Positive Ratings:
    1,715
    what is this I dont even..

    no seriously I have no idea what's going on in these screens.
    can you elaborate on these?
     
  3. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    VVIS broke.

    Uh... fix it I guess.
     
  4. Revocare

    Revocare L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    Haha, sure thing.

    I'm able to move around normally, collisions work and such. From different places in the map, different faces render and such. That's pretty much it. Is this a lighting issue? Some faces are entirely black.
     
  5. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Yes, VVIS is crashing or something and it's causing it to freak out. Check your compile log.
     
  6. Revocare

    Revocare L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    So it's a leak? Nothing is outside the skybox, and even though it's the lazy hollow cube style...
     
  7. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    If you are using the bigbox method of sealing, it is highly likely the areas that shouldn't be will be rendered, as it appears is happening.
    The nodraw is a displacement. All tool textures functions are disabled on displacement surfaces and render as in Hammer.
     
  8. Kagatos

    Kagatos L1: Registered

    Messages:
    31
    Positive Ratings:
    0
    Isn't this something that happens when you have a leak into the void?

    I could have sworn that I had this happen to me once and I'm pretty sure that was the cause.

    Check for leaks, and make sure everything is sealed. Also, displacements don't seal so check that you have brushes behind em. That's all I can think of at the moment.
     
  9. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Show us your compile log.

    No for the love of god this isn't a leak, though that's probably why it wasn't loading before.
     
  10. Revocare

    Revocare L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    ** Executing...
    ** Command: "c:\program files (x86)\steam\steamapps\brookchipman\sourcesdk\bin\orangebox\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\brookchipman\team fortress 2\tf" "C:\Users\Chipman\Desktop\Dump maps here\Srs bsns\cp_descent.vmf"

    Valve Software - vbsp.exe (Jul 7 2010)
    6 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\brookchipman\team fortress 2\tf\materials
    Loading C:\Users\Chipman\Desktop\Dump maps here\Srs bsns\cp_descent.vmf
    Patching WVT material: maps/cp_descent/nature/blendgroundtograss008_wvt_patch
    Patching WVT material: maps/cp_descent/nature/blendrockgroundwallforest002_wvt_patch
    Patching WVT material: maps/cp_descent/cp_mountainlab/nature/blendrocktograss002_wvt_patch
    Patching WVT material: maps/cp_descent/nature/blendgroundtograss007_wvt_patch
    Patching WVT material: maps/cp_descent/cp_mountainlab/nature/groundtograss001_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...
    Merged 68 detail faces...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    done (0)
    writing C:\Users\Chipman\Desktop\Dump maps here\Srs bsns\cp_descent.prt...Building visibility clusters...
    done (0)
    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!
    Finding displacement neighbors...

    ** Executing...
    ** Command: "c:\program files (x86)\steam\steamapps\brookchipman\sourcesdk\bin\orangebox\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\brookchipman\team fortress 2\tf" -fast "C:\Users\Chipman\Desktop\Dump maps here\Srs bsns\cp_descent"

    Valve Software - vvis.exe (Jul 7 2010)
    fastvis = true
    6 threads
    reading c:\users\chipman\desktop\dump maps here\srs bsns\cp_descent.bsp
    reading c:\users\chipman\desktop\dump maps here\srs bsns\cp_descent.prt
    1014 portalclusters
    3569 numportals
    BasePortalVis: 0...1...2...3...4...5...6...7...8...9...10 (1)
    Optimized: 39910 visible clusters (0.00%)
    Total clusters visible: 915590
    Average clusters visible: 902
    Building PAS...
    Average clusters audible: 1013
    visdatasize:262518 compressed from 259584
    writing c:\users\chipman\desktop\dump maps here\srs bsns\cp_descent.bsp
    1 second elapsed

    ** Executing...
    ** Command: "c:\program files (x86)\steam\steamapps\brookchipman\sourcesdk\bin\orangebox\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\brookchipman\team fortress 2\tf" "C:\Users\Chipman\Desktop\Dump maps here\Srs bsns\cp_descent"

    Valve Software - vrad.exe SSE (Jul 7 2010)

    Valve Radiosity Simulator
    6 threads
    [Reading texlights from 'lights.rad']
    [34 texlights parsed from 'lights.rad']

    Loading c:\users\chipman\desktop\dump maps here\srs bsns\cp_descent.bsp
    Setting up ray-trace acceleration structure... Done (4.76 seconds)
    3553 faces
    1289174 square feet [185641056.00 square inches]
    277 Displacements
    165398 Square Feet [23817366.00 Square Inches]
    3553 patches before subdivision
    59063 patches after subdivision

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Users\Chipman\Desktop\Dump maps here\Srs bsns\cp_descent.bsp" "c:\program files (x86)\steam\steamapps\brookchipman\team fortress 2\tf\maps\cp_descent.bsp"

    And thank you for the responses, you guys are great here.
     
  11. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Don't run VVIS on fast. It appears to be causing the error.
     
    • Thanks Thanks x 1
  12. red_flame586

    red_flame586 L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    108
    Nodraw on a displacement and you're running fast vis, try and fix that.

    EDIT: NIGA'D
     
    • Thanks Thanks x 1
  13. Revocare

    Revocare L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    Oh god, ran it on normal and we're back to crashing on loading game data/resources.

    EDIT: Found a displacement-Player Clip and destroyed that ho.
     
    Last edited: Jan 17, 2011
  14. Revocare

    Revocare L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    My derpy problem is solved. Thanks a ton guys.