Compiling Issue - can't find cause of the leak

Discussion in 'Mapping Questions & Discussion' started by Kill_the_Bug, Jul 5, 2011.

  1. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,466
    Positive Ratings:
    237
    I keep getting a leak message can't find the error - can anyone help? ran BSP and fast vis only

    I've even enclosed the entire map in a box - sealing it and I still get leak message - here's the log:


    ** Executing...
    ** Command: "c:\steam\steamapps\kill_the_bug\sourcesdk\bin\orangebox\bin\vbsp.exe"
    ** Parameters: -game "c:\steam\steamapps\kill_the_bug\team fortress 2\tf" "E:\C drive backup\Desktop\maps\gold_heist_Canyon_B1.vmf"

    Valve Software - vbsp.exe (Jul 7 2010)
    4 threads
    materialPath: c:\steam\steamapps\kill_the_bug\team fortress 2\tf\materials
    Loading E:\C drive backup\Desktop\maps\gold_heist_Canyon_B1.vmf
    Patching WVT material: maps/gold_heist_canyon_b1/nature/blendgroundtograss001_wvt_patch
    Patching WVT material: maps/gold_heist_canyon_b1/brick/blendcobbletocobblesnow001_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
    **** leaked ****
    Processing areas...done (0)
    Building Faces...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    NODRAW on terrain surface!
    done (0)
    Creating default LDR cubemaps for env_cubemap using skybox materials:
    skybox/sky_day01_01*.vmt
    ! Run buildcubemaps in the engine to get the correct cube maps.
    Creating default HDR cubemaps for env_cubemap using skybox materials:
    skybox/sky_day01_01*.vmt
    ! Run buildcubemaps in the engine to get the correct cube maps.
    Finding displacement neighbors...
    Found a displacement edge abutting multiple other edges.
    Warning: invalid neighbor connection on displacement near (2080.00 1203.00 301.00)
    Warning: invalid neighbor connection on displacement near (2080.00 1183.00 -192.00)
    Warning: invalid neighbor connection on displacement near (2128.00 976.00 307.40)
    Warning: invalid neighbor connection on displacement near (2080.00 888.00 321.00)
    Warning: invalid neighbor connection on displacement near (2080.00 933.56 -192.00)
    Warning: invalid neighbor connection on displacement near (2640.00 1309.00 381.00)
    Warning: invalid neighbor connection on displacement near (2640.00 1354.56 -132.00)
    Warning: invalid neighbor connection on displacement near (2688.00 1349.00 359.68)
    Warning: invalid neighbor connection on displacement near (2640.00 1624.00 361.00)
    Warning: invalid neighbor connection on displacement near (2640.00 1604.00 -132.00)
    Warning: invalid neighbor connection on displacement near (2128.00 928.00 299.68)
    Warning: invalid neighbor connection on displacement near (2688.00 1397.00 367.40)
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (2) (474967 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Compacting texture/material tables...
    Reduced 3058 texinfos to 1039
    Reduced 25 texdatas to 23 (664 bytes to 544)
    Writing E:\C drive backup\Desktop\maps\gold_heist_Canyon_B1.bsp
    5 seconds elapsed

    ** Executing...
    ** Command: Copy File
    ** Parameters: "E:\C drive backup\Desktop\maps\gold_heist_Canyon_B1.bsp" "c:\steam\steamapps\kill_the_bug\team fortress 2\tf\maps\gold_heist_Canyon_B1.bsp"
     
  2. Ravidge

    aa Ravidge Grand Vizier

    Messages:
    1,544
    Positive Ratings:
    2,495
    You have nodrawed displacements and some other displacement errors as well. Also besides the point: your map doesn't have a gamemode prefix in it's name, and capital letters should be avoided.
     
  3. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    You might have to recenter your origins, can you load a pointfile? (Go to map >load pointfile. this will give you a red line starting at the leaking entity and if you follow the line, it will pass through the leak at some point)... it might also be an area portal leak, but I don't see anything saying somehting about that.
     
  4. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,466
    Positive Ratings:
    237
    There was no point file file generated but just after I posted I got an idea.

    I deleted all the cube maps then ran it - this time it identified a brush that had something weird with it - I deleted it - ran again and no issues.

    Got to say this was the weirdest one I've ever seen.