VTFedit import problem - Image gets corrupted

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

Simulacron

L-3: Simulated Member
aa
Feb 17, 2016
316
I'm trying to import a texture into hammer, that I want to use as an overlay.
Note that the picture has no texture for the background, as it is intended as a logo to put at a wall. I also created a .tga file of this image to avoid any lose of quality.The texture itself is 512 by 512 pixels, so there shouldn't be any problems with the size.
However, when I open up my tga file (and also the png) in Vtfedit with the "Import" option I get the following texture displayed:
error1.jpg
It seems like the texture got corruted or some sort of setting occured.
Here are my Import settings:
setting1.jpg setting2.jpg setting3.jpg
What am I doing wrong? Are my input settings wrong?
 
Last edited:

Izotope

Sourcerer
aa
May 13, 2013
700
Should be fine in hammer/game, VTFEdit shows stuff weirdly for me too sometimes, but they're okay when used in the editor.
 

Simulacron

L-3: Simulated Member
aa
Feb 17, 2016
316
Sadly it isn't. here are the pictures of the hammer and in-game view (I'm mapping for CS:GO btw)
hammer.jpg game.jpg
And if someone knows, what command to use in the vmf to make the background transparent I would highly appreciate that!

Edit: Ok, this is a little bit awkward. I found out how to fix it being not transparent and it fixes all problems. The overlay is now shown correct in-game and in hammer. Thanks for your help Izotope!
 
Last edited: