Trigger_teleport (Advanced question, beware!)

Discussion in 'Mapping Questions & Discussion' started by who_is_scorpion, Aug 20, 2009.

  1. who_is_scorpion

    who_is_scorpion L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    I have been trying to fix this problem for over a day, no luck.

    I am making a jump map for TF2 (This is where the demo or soldier have to do certain skill jumps to reach the end cp).

    Below you see the picture of the jump.

    http://img21.imageshack.us/img21/3750/jumpv.jpg

    The purpose of this tall tower is to climb it within a certain period of time (45 seconds).

    The trigger entity you see is actually two overlapped ones (trigger_multiple and trigger_teleport). I added a teleport destination and logic_timer at the bottom of the tower.

    Here is how it's set up:
    --------------------------------------------
    Trigger_multiple has four outputs.

    OnStartTouch timer enable
    OnEndTouch timer disable
    OnStartTouch teleport enable delay:45
    OnStartTouch teleport disable delay:45.05

    Trigger_teleport is set to start disabled.

    Timer has two outputs.

    OnTimeHigh teleport enable
    OnTimeHigh teleport disable Delay:0.05
    --------------------------------------------

    I test out the map and it partially works. You get teleported back if you stay in the trigger_multiple area for 45 seconds (which is good). It doesn't work you down out of the trigger area and don't get teleported (the delay does not reset and is still counting down from the time you entered the area). This means when you try and do the jump again, you get teleported 45 seconds from the PREVIOUS time you entered the trigger area.

    What I WANT is for the delay to reset every time trigger_multiple is fallen out of.

    Help:(
     
  2. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    trigger_multiple:
    OnStartTouch > logic_relay > Trigger
    OnEndTouch > logic_relay > CancelPending

    logic_relay:
    OnTrigger > teleport > Enable > delay: 45
    OnTrigger > teleport > Disable > delay: 45.05

    When you enter the trigger the relay is fired and the teleport enable put into queue. When you leave the trigger the relay's queue is cleared. :)
     
  3. who_is_scorpion

    who_is_scorpion L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    The teleport doesn't work =\

    I put in exactly what you typed.

    Does it matter if the tele_trigger is initially disabled?
     
  4. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    What part doesn't work? All of it? Does it still behave as before?
    and I hope you don't mean exactly as I typed. The second part of each output is supposed to be the name of the entity I mention.
     
  5. who_is_scorpion

    who_is_scorpion L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    Ok, forget my last post.

    No, I didn't type exactly what you typed :p

    I go in the trigger area and wait. After 45 second, I get tele'd back.

    Good.

    Then I quickly go back to the trigger area and get tele'd back instantly.

    I have to wait 45 seconds AFTER the last time I entered the trigger area.

    I don't want to have to wait.

    But it did solve my previous problem of the timer not resetting :D
     
    Last edited: Aug 20, 2009
  6. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    Oh right, I wasn't thinking it through and just adapted what you had. The problem is the instant the teleport is enabled you leave the multiple and the relay gets cleared before the teleport turns off, so...

    Remove the disabling from the relay and then on the trigger_teleport do:
    OnStartTouch > !self (actually use !self, it's a special thing) > Disable
     
  7. who_is_scorpion

    who_is_scorpion L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    It worked perfectly.

    I love you.