Teleporter(Engineer) destruction

Discussion in 'Mapping Questions & Discussion' started by phatal, Feb 8, 2008.

  1. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    There's this map I've been working on that you can build the entrance and exit for the teleporters but when the exit is placed in some places (most places) someone tries to use it the exit destroys itself and the person is not teleported. This happens on displacement ground and solid ground as well.
     
    • Thanks Thanks x 1
  2. TheFragMan

    TheFragMan L1: Registered

    Messages:
    33
    Positive Ratings:
    1
    I have the same issue with one of my maps. Also, if you've played Lazytown, the same thing happens on there. From what I've heard, though, nobody really knows why. But I would love to be proven wrong.
     
  3. Deadeye2007

    Deadeye2007 L2: Junior Member

    Messages:
    52
    Positive Ratings:
    0
    Very strange. Sounds like a coding bug to me.
     
  4. bkb

    bkb L1: Registered

    Messages:
    12
    Positive Ratings:
    2
    Hate to dig up a dead thread, but I am having this problem.

    Is there any answer for this? There's one map I play on, and I can't get a tele to work on most of the level.

    ..and no, there's plenty of room. Flat brush, open space 50 feet wide in all directions, and the exit just explodes. It happens all over the level. Everywhere!

    Anyone figure out what is causing this or how to fix it?
     
  5. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    586
    It's a totaly mystery. But don't feel bad, it happens on Valve maps too, most notably Badwater and Goldrush
     
  6. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    571
    I solved this bugger :)

    there are 2 reasons, but they have the same source:
    the game thinks, it will spawn the player inside an entity

    1.props:
    most probs have a small boundary/collision box; others, like the explosion particles have a huge one, it encloses every debris of the explosion. so, specifically look for props_dynamic that use much space for their animation
    solution to the explosion depris problem: set collision to non-solid

    2.func-lod
    lets say you make a room, select all walls, make them one func_lod
    the engine thinks, its one giant object/entity, when you place an exit inside the room, the game would spawn the player inside an entity, so it destructs the exit to avoid that


    in general, if you want to find out why, isolate the area, where the teleport destructs, and narrow the problem down
     
    • Thanks Thanks x 5
    Last edited: Apr 4, 2009
  7. bkb

    bkb L1: Registered

    Messages:
    12
    Positive Ratings:
    2
    Thanks for your input!

    I am not familiar with func_lod, but I do understand your concern.

    Unfortunately, there are no props. So I doubt it is the prop thing.

    The problem is that it is a really basic level, no props, with basic geometry. A couple control points are the only props in the level. The other entities are basic things like cubemaps, env_sun, etc.

    I will keep searching though! Try to look through all the entities... I can't isolate the area, because it's the whole level!

    Thanks for pointing me in a direction though! :D Hopefully I can find something.. but I'm still fairly stumped
     
  8. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    571
    got some free time, send me your vmf to eerie_1[at]web.de if you want me to have a look at it :)
     
  9. bkb

    bkb L1: Registered

    Messages:
    12
    Positive Ratings:
    2
    Ok I think I got it.. after looking around I found that the clip brushes surrounding the level (AKA the demoman cage) were set to func_brush and grouped together. (I noticed that huge blue func ball floating over the middle of the level, not in the brushes themselves, when selected)

    Changed them to func_deatil, voila, teleporters now work.

    Could this be the solution to this age-old problem? Either way, it's the solution to my current problem!

    Thanks again eerieone~!
     
    • Thanks Thanks x 2
  10. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    571
    yeah, its the solution :)
    func_brush-es are entities, so yeah, thats always the reason for teleporters exploding :)
     
  11. VelvetFistIronGlove

    aa VelvetFistIronGlove

    Messages:
    567
    Positive Ratings:
    437
    You're on the money, eerieone! I just built a quick test map to confirm your theory, and indeed the teleport exits contained within the bounds of a partially solid brush entity or some props exploded when teleporting to them.

    This has been a mystery to me since forever, but no longer.
     
  12. kwagner

    kwagner L2: Junior Member

    Messages:
    92
    Positive Ratings:
    6
    Thanks for this thread. I've a spot on my map where teleports were blowing up, and I was figuring it was because the ceiling was too low. I had built it well above the expected height, but they'd still pop. This grouped brush idea sounds like the explanation.

    Very helpful. :thumbup1: