Payload cart not following the path set for it

Discussion in 'Mapping Questions & Discussion' started by actioninja, Aug 29, 2014.

  1. actioninja

    actioninja L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Problem is as described in title.
    I don't know how best to describe it. I have an unfinished cart path set in hammer, but when I go to test it the cart is nowhere near it. The directions it takes if you noclip near it seem to be the path, but it does things like freak out at turns, and the like. The map isn't ready for normal play, and I am trying to make it quickly because I am not sure if the concept I have will even work, so there is sharp corners for the turns. I am not sure if that would affect anything. I am also using the gamemode templates from the ultimate map resource pack.

    Screenshots:
    Hammer:
    [​IMG]
    Where the cart is:
    [​IMG]
    Where it should be:
    [​IMG]
    Another angle ingame for reference:
    [​IMG]
     
  2. Waffe

    Waffe L4: Comfortable Member

    Messages:
    192
    Positive Ratings:
    184
    The origin of the train must be off. Make sure you have the "Toggle helpers" button pressed and after selecting the cart, look for a small white circle. Move this to the center of the train/cart
     
    • Thanks Thanks x 1
  3. henke37

    aa henke37

    Messages:
    1,878
    Positive Ratings:
    442
    Linear interpolation tends to work badly at discontinuities. And the rotation of the cart is linearly interpolated. And your path has major discontinuities at the turns. Add in between path nodes.
     
  4. actioninja

    actioninja L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Helpers were screwed up, that was it.