Model compiling error

Discussion in 'Mapping Questions & Discussion' started by Spike, Mar 24, 2008.

  1. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    I've made a cannonball and when I try to compile it gives me this error:

    That's my .QC file:


    If I delete this part
    Code:
    {
       $Mass 40
       $concave
    }
    It compiles but the prop doesn't have any physics ingame and is non-solid.
     
  2. Shmitz

    aa Shmitz Old Hat

    Messages:
    1,129
    Positive Ratings:
    742
    I've seen this problem before, and really don't know what causes it. Try retyping the entire thing in a brand new text file. There might be some subtle formatting issue that the parser doesn't like. The model compiler parser is really picky about things sometimes.
     
  3. Hawk

    Hawk L7: Fancy Member

    Messages:
    419
    Positive Ratings:
    212
    I think the problem may be with your collision model. The compiler is awfully picky about some strange things on your collision model, but look it over and see if these things apply:

    - It should be a completely enclosed convex shape.
    - It must have a UV map and texture applied. The don't need to look good, but they must exist.

    I've made a custom objects tutorial here: http://forums.tf2maps.net/showthread.php?t=838
    It could prove helpful.
     
  4. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    I think the way to fix that is to check a box on the studiomdl, but not sure. Cannonball is now well compiled.