Making a custom skybox question.

Discussion in 'Mapping Questions & Discussion' started by level 100 pidgey, May 31, 2017.

  1. level 100 pidgey

    level 100 pidgey L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    What is this menu supposed to look like when creating the .vtfs for a skybox? I believe I've done everything else correctly but in-game it shows as purple and black checkers.

    [​IMG]
     
  2. Asd417

    aa Asd417 L1: Registered

    Messages:
    697
    Positive Ratings:
    482
    Purple checker most likely means incorrect directories. you should check that again
     
  3. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,213
    Specifically, incorrect VTF directory/filename in your VMT, since being unable to find the VMTs altogether will just give you the trippy nodraw sky thing.
     
    • Thanks Thanks x 1
  4. Lampenpam

    aa Lampenpam

    Messages:
    994
    Positive Ratings:
    329
    unrelated to your problem, but change "Alpha format" to DXT1. DXT5 is the same format but with an alpha channel. Since you're probably not using an alpha channel for a skybox texture, your vtf will have bigger file size without any benefit.
    Only set it to DXT5 when you need an alpha channel, like a transparent texture or when you use something like $selfillum. Otherwise use DXT1 for lower file size.

    Also a skybox texture doesn't need mipmaps I believe. Even more kbits saved~
     
    Last edited: Jun 1, 2017
  5. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,213
    Doesn't the fact that there are options for both in the dialog box mean "use this format if there's an alpha channel in the source image and that format if there's not"? That's how I'd always interpreted it.
     
    • Agree Agree x 1
  6. Lampenpam

    aa Lampenpam

    Messages:
    994
    Positive Ratings:
    329
    This is not false, however an image that isn't transparent can still have an alpha channel you aren't aware of. Often when I open png images in a image editing tool, it has an alpha channel despite not having any transparent areas. Unless you remove the alpha channel in your software, VTFEdit will compile the alpha channel too!

    Since I believe more people know what an alpha channel is than people who know how to remove them in an editing programm I just recommend setting option for alpha to DXT1 in VTFEdit when compiling a untransparent image.

    This actually just reminded me of thread about Watergate textures! @Bakscratch made the same mistake, though he ignored my advice :I https://tf2maps.net/threads/watergate-models-textures-and-overlays.23922/
     
    Last edited: Jun 2, 2017