Invisible Prop

Discussion in 'Mapping Questions & Discussion' started by horza, Jan 11, 2008.

  1. horza

    horza Guest

    Positive Ratings:
    0
    hey all,

    I am having a total nightmare trying to make custom props using 3ds max :(

    I can create MDLs with out a problem and load them into Hammer, the problems come when trying to get the texture to show up.
    Originally i had the pink checker patteren that is shown in http://tf2maps.net/showthread.php?t=194 and when viewing my custom texture using the texture browser it was also showing as pink checks.

    However, using VTFedit to create my VMT i can now see my texture in the browser, but the model is invisible. Even once it's compiled it's invisible, i can walk on it; the correct sound plays, and shoot at it but can't see it :(
    If i rename the VMT and restart Hammer the model appears but with the pink checks again. so i think the model is looking at the correct VMT file and my paths are correct.
    I have used MDLTextureInfo to confirm paths and file name. the texture is just a light blue 512x512 image just as a test.
    It doens't show in ModelViewer either, but i can see the wireframe and collision box.
    The model has a UVWmap, set to Box, and looks fine when rendered in Max

    any help appreciated, i can post more info if needed. I just can't work out where the problem is, vmt, vtf, qc or Max

    thanks in advance

    Horza
     
  2. Snipergen

    Snipergen L13: Stunning Member

    Messages:
    1,053
    Positive Ratings:
    150
    probably your paths. Paste all you vmt and qc info here please.
     
  3. horza

    horza Guest

    Positive Ratings:
    0
    thanks for the reply snipergen :)

    here is my qc
    Code:
    $modelname "horza\hullblue.mdl"
    $cdmaterials "models\horza\blue"
    
    $scale  1
    $surfaceprop "metal"
    
    $staticprop
    
    
    $body studio "hullblue"
    
    $sequence idle "hullblue_idle" fps 1
    
    $collisionmodel "hullblue_phys" {
        $concave
    }
    
    and the VMT (generated from VTFedit)

    Code:
    "LightmappedGeneric"
    {
    	"$basetexture" "models/horza/blue/blue"
    	"$surfaceprop" "Metal"
    }
    
    current paths being used:
    ...Team fortress 2\tf\models\horza\hullblue.mdl
    ...Team fortress 2\tf\materials\models\horza\blue\blue.vmt & blue.vtf

    MDLTextureInfo output:
    Code:
    GENERAL INFO
    ============
    Model File: C:\Program Files\Steam\SteamApps\<steamID>\team f
    \horza\hullblue.mdl
    Internal Name: "horza\hullblue.mdl"
    ID Tag: 1414743113
    Version: 48
    Length: 1720 bytes
    CRC: 47C083D0
    Number of Textures: 1
    Number of Textures Paths: 1
    
    TEXTURE NAMES
    =============
    Texture 1 - "blue.vmt"
    
    TEXTURE FOLDER(S)
    =================
    Texture path 1 - "<Mod Folder>\materials\models\horza\blue\"
    
    thanks for your help

    Horza
     
  4. horza

    horza Guest

    Positive Ratings:
    0
    Hey,
    i've notive this error in the tf2 console when running the map with the prop in....

    "Material models/horza/blue/blue does not support vertex format used by the mesh (maybe missing fields or mismatched vertex compression?), mesh will not be rendered. Grab a programmer!"

    can't find any reference to this error using google.
    I thought maybe it's didn't like the UVW Map modifier i'd used in Max so i've now done a full UVW Unwrap, but get the same error.

    anyone had this error before?

    cheers

    Horza
     
  5. Snipergen

    Snipergen L13: Stunning Member

    Messages:
    1,053
    Positive Ratings:
    150
    I dont, know, maybe try what i have but change the logical paths and names?

    I have 1 map where i put all custom models in, i call it custom

    QC in D:\Steam\steamapps\snipergen\sourcesdk_content\cstrike\modelsrc\custom
    also i have my smds there.
    VTFD:\Steam\steamapps\snipergen\counter-strike source\cstrike\materials


    VMT
    D:\Steam\steamapps\snipergen\counter-strike source\cstrike\materials\models\custom
    What gives me this:

    [​IMG]
     
  6. horza

    horza Guest

    Positive Ratings:
    0
    thanks for the reply snipergen but the main issue turned out to be the VTF

    I am now using "VertexLitGeneric" in the VMT and when saving the VTF as BGRA8888 format i uncheck the Vertex Texture option that the photoshop plugin set by default.
    I've resave my other vfts and they now work too

    i tried "$model" 1, thought that was going to be it when i saw it on the Valve pages, but it doesn't seem to make any difference. I removed it now and the texture still works.

    thanks

    Horza