1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

How is it that a func_respawnroomvis can leak?

Discussion in 'Mapping Questions & Discussion' started by Open Blade, Jun 27, 2009.

  1. Open Blade

    Open Blade L7: Fancy Member

    Messages:
    439
    Positive Ratings:
    34
    Never heard of this before, it's not outside the map boundries and it's not within a world brush, how is it that this is leaking?
     
  2. Loc_n_lol

    Loc_n_lol L10: Glamorous Member

    Messages:
    726
    Positive Ratings:
    304
    Load the pointfile and see where it leads you, you may get a surprise ?
     
  3. Open Blade

    Open Blade L7: Fancy Member

    Messages:
    439
    Positive Ratings:
    34
    It points from the void at the bottom of the map up into the floor, which seals that portion of the map. I doubled checked and the floor is sealed. I turned off all entities and tool brushes and ran the compile again and it says leaked but doesn't say where and when I try to load a pointfile, there isn't one. Does that mean there isn't a leak if it won't load the pointfile? It must know that the entity is still there because the portalside errors don't show up when the areaportals are not turned off.


    ** Executing...
    ** Command: "d:\steam\steamapps\azhelton@cox.net\sourcesdk\bin\orangebox\bin\vbsp.exe"
    ** Parameters: -game "d:\steam\steamapps\azhelton@cox.net\team fortress 2\tf" "D:\Steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\Blades Maps\pl_whitetanks"

    Valve Software - vbsp.exe (May 19 2009)
    1 threads
    materialPath: d:\steam\steamapps\azhelton@cox.net\team fortress 2\tf\materials
    Loading D:\Steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\Blades Maps\pl_whitetanks.vmf
    Patching WVT material: maps/pl_whitetanks/nature/blendgroundtograss005_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    **** leaked ****

    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (4096.0 14848.0 -597.5)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3584.0 15360.0 -597.5)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (2560.0 15360.0 -597.5)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (4096.0 13824.0 -597.5)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (4096.0 12800.0 -597.5)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (4096.0 11776.0 -597.5)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3332.0 10240.0 -597.5)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3844.0 10240.0 -597.5)
    Leaf 0 contents: CONTENTS_SOLID
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:

    *** Suppressing further FindPortalSide errors.... ***
    Processing areas...done (0)
    Building Faces...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (0)
    *** Error: Skybox vtf files for skybox/sky_dustbowl_01_hdr weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_dustbowl_01_hdr to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_dustbowl_01_hdr weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_dustbowl_01_hdr to build the default cubemap!
    Finding displacement neighbors...
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (0) (399828 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Compacting texture/material tables...
    Reduced 2791 texinfos to 833
    Reduced 71 texdatas to 60 (1462 bytes to 1186)
    Writing D:\Steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\Blades Maps\pl_whitetanks.bsp
    3 seconds elapsed

    ** Executing...
    ** Command: "d:\steam\steamapps\azhelton@cox.net\sourcesdk\bin\orangebox\bin\vvis.exe"
    ** Parameters: -game "d:\steam\steamapps\azhelton@cox.net\team fortress 2\tf" -fast "D:\Steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\Blades Maps\pl_whitetanks"

    Valve Software - vvis.exe (May 19 2009)
    fastvis = true
    1 threads
    reading d:\steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\blades maps\pl_whitetanks.bsp
    reading d:\steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\blades maps\pl_whitetanks.prt
    LoadPortals: couldn't read d:\steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\blades maps\pl_whitetanks.prt


    ** Executing...
    ** Command: Copy File
    ** Parameters: "D:\Steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\Blades Maps\pl_whitetanks.bsp" "d:\steam\steamapps\azhelton@cox.net\team fortress 2\tf\maps\pl_whitetanks.bsp"
     
    Last edited: Jun 27, 2009
  4. Open Blade

    Open Blade L7: Fancy Member

    Messages:
    439
    Positive Ratings:
    34
    It must have something to do with having a spawn room trigger assigned to it. I copied it from another area on my map and set it in place because there will be a room there eventually. I deleted it and now it's fine.
     
  5. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    571
    these mean m...fuckers are most probably causing your problem

    vbsp can´t determine to which visleaf they belong and gets frenzy and bugs out

    these errors can be caused by areaportals cutting into big brushes/ way to big brushes/ brushes cut by hint-brushes

    load up the coordinates provided by the error-report and check which brush might be a candidate of the causes i stated above
    you can then either do something with the brush itself (slit it, etc...) or with the areaportal/hintbrush


    hope that helps

    this error is annoying, but i believe one you get rid of that, you get a bugfree report
     
  6. Open Blade

    Open Blade L7: Fancy Member

    Messages:
    439
    Positive Ratings:
    34
    I got it fixed. I had some chicken wire on the back of spawn room opening windows and I forgot that any time you have a translucent texture, you need to make it a func_detail and then put a areaportal there also. Once I did that I got it working fine. I'm assuming some of the same rules apply to func_respawnroomvis. It will say it leaks because if there is a translucent texture showing to the other side, essentially it's acting like an areaportal does. It's saying it can't keep enemy's out because there is a way for them to get to the other side, via the translucent texture brush. I haven't put the respawnvis back in yet but I assume it will work just fine now that the area is sealed with areaportal. Everything is good now. Thanks.
     
    Last edited: Jun 27, 2009