Help!

Discussion in 'Mapping Questions & Discussion' started by SturmTrpr, Aug 3, 2015.

  1. SturmTrpr

    SturmTrpr L1: Registered

    Messages:
    31
    Positive Ratings:
    9
    I'm having some issues compiling. usually when I compile for a game test it would bring up all the standard stuff. like portal flow, visleafs, etc, but recently it has stopped doing that. Heres the text from the compile window:

    ** Executing...
    ** Command: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1.vmf"

    Valve Software - vbsp.exe (Jul 2 2015)
    2 threads
    materialPath: C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Error: displacement found on a(n) func_detail entity - not supported (entity 354, brush 0)


    ** Executing...
    ** Command: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1"

    Valve Software - vvis.exe (Jul 2 2015)
    2 threads
    reading c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1.bsp
    Error opening c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1.bsp

    ** Executing...
    ** Command: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1"

    Valve Software - vrad.exe SSE (Jul 2 2015)

    Valve Radiosity Simulator
    2 threads
    [Reading texlights from 'lights.rad']
    [39 texlights parsed from 'lights.rad']

    Loading c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1.bsp
    Error opening c:\program files\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_waterfall_a1.bsp" "C:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf\maps\koth_waterfall_a1.bsp"

    The command failed. Windows reported the error:
    "The system cannot find the file specified."

    I'm still pretty new to map making so this confuses me. I would like to know how I am supposed to fix this so it is not dependent on a bsp file, and it will go back to the standard compile. I know that the solution might be simple and I simply haven't come across it, but any help would be appreciated.
     
    Last edited: Aug 3, 2015
  2. MaccyF

    aa MaccyF Notoriously Unreliable

    Messages:
    907
    Positive Ratings:
    1,467
  3. SturmTrpr

    SturmTrpr L1: Registered

    Messages:
    31
    Positive Ratings:
    9
    No, but I will give it a try.
     
  4. henke37

    aa henke37

    Messages:
    1,890
    Positive Ratings:
    443
    There's your problem. Move that brush back to the world.
     
  5. SturmTrpr

    SturmTrpr L1: Registered

    Messages:
    31
    Positive Ratings:
    9
    Thank you so much! That fixed it. the brush work was the issue. The website also found more problems that I fixed. I think I will put this website in my favorites as I feel I'll need it again soon. Thanks!