Hammer (recently) won't show or use my custom tutorials- help?

Discussion in 'Mapping Questions & Discussion' started by (s2a) yahodahan, Mar 23, 2011.

  1. (s2a) yahodahan

    (s2a) yahodahan L3: Member

    Messages:
    144
    Positive Ratings:
    18
    Hammer (recently) won't show or use my custom materials- help?

    Hi all, thanks for any help-

    I'm going back and editing an old map (this one)

    Seems my custom textures are no longer showing up at all, anymore. Granted, I've fully formated my comp since I last worked on this map, so I had to place the files/folders back in manually, however I've painstakingly made certain I did this correctly, and checked every option I can find. No luck!

    Let me give a specific example- the big "Shipment" sign above the gate uses a texture called "shipment_sign", however is currently showing up simply white. In the "Face Edit Sheet", under "Current Texture", it shows "CUSTOM MODELS/SHIPMENT/SHIPMENT_SIGN". The Image preview is black, showing "No Image". Obviously, Hammer isn't able to find it.

    However, looking at the folder structure, I definitly have "shipment_sign.vmt" and "shipment_sign.vmt" in the folder "...\team fortress 2\tf\materials\custom models\shipment"

    Next, I check the VMT, and it is proper as well-
    Code:
    "LightmappedGeneric"
    {
    	"$basetexture" "custom models/shipment/shipment_sign"
    	"$surfaceprop" "Metal"
    }
    At this point, I was stumped, but didn't give up, and eventually found that if I moved the VMT file into the root of "materials", it would show up in Hammer. Okay, it's a start- however, this breaks the link that my object has in Hammer, of course- and there are lots of items with this issue, I'd rather not repath them all (teeedius!).

    Next, I dug around in the options, and found that Hammer was excluding the "models" folder from being loaded into the materials. I thought, "perhaps it's just searching for "models", and my folder is called "custom MODELS", and therefore ruling my folder out too!"

    So, I removed that folder name from the "block list" in "tf.fgd", made sure it was gone from the "Material directory exclusion list", restarted Hammer, and- fail. Still not showing any textures within that folder.

    At this point, I'm at a complete loss. I've googled all over on this, and am not finding a fix. Please, if anyone can think of what I'm doing wrong, or if something has changed in Hammer that I need to work around, please let me know!!

    Thanks again :)
     
    Last edited: Mar 24, 2011
  2. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    So, this sign of yours. Is it a brush or a model? Because models need VertexLitGeneric instead of LightmappedGeneric. And if it's a brush, you were better off sticking the texture files in /materials/signs or something.
     
  3. (s2a) yahodahan

    (s2a) yahodahan L3: Member

    Messages:
    144
    Positive Ratings:
    18
    Hi Steve- It is actually a brush, yes. That's just bad naming convention on my part...it's just that I have many parts that I also included in that not-so-aptly-named folder, and I would really like Hammer to simply "see" them right there. Thanks for the suggestion though!
     
  4. jpr

    aa jpr

    Messages:
    1,095
    Positive Ratings:
    507
    custom tutorials :p
     
  5. (s2a) yahodahan

    (s2a) yahodahan L3: Member

    Messages:
    144
    Positive Ratings:
    18
    Ha! How did I type "tutorials" instead of "materials"? Title changed :)

    Any suggestions?
     
  6. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    My guess would be that you have a space in the folder name, and a lot of things don't like spaces.