Hammer not launching game .exe after compile

Discussion in 'Mapping Questions & Discussion' started by Tobias Greenich, Jan 3, 2008.

  1. Tobias Greenich

    Tobias Greenich L1: Registered

    Messages:
    15
    Positive Ratings:
    0
    Heya guys, new-ish to mapping and to the forum, and there's some great stuff around here, gotta say!

    Alright, heres the thing. I'm working with a basic map right now, and I've done the basic gray/orange texturing for this stage of it. My compile works just fine... but after the compile, TF2 won't launch to let me playtest it.

    The map works just fine if I open TF2 up myself and start a server with my map. It just won't load from Hammer. Not a big deal, I know, but it kinda bugs me. Any ideas? I've tried replacing the hl2.exe with the steam.exe, but no dice.

    And as a bonus round, are you still able to use the CST compile tools for TF2, or should I stick with the default valve ones for now?

    Thanks for your time!
     
  2. Paddy

    Paddy L1: Registered

    Messages:
    40
    Positive Ratings:
    0
    have you remembered to check the box "Launch on Compile" in the run map settings thing?
     
  3. Crimson

    Crimson L3: Member

    Messages:
    119
    Positive Ratings:
    1
    It has been a while since I started mapping, but there was something wrong with it. I think it errored out or something when Hammer started it. Just do it how you are now. If you are compiling and checking a lot, just run TF2 windowed so you dont have to load it each time.
     
  4. Tobias Greenich

    Tobias Greenich L1: Registered

    Messages:
    15
    Positive Ratings:
    0
    There's a "Do not run the game after compiling" checkbox in the easy view of the compiler, and the expert view has the $game exe thingie checked of, if that's what you mean. I'll peek around again once I get home from work.

    Crimson, thas probably what I'll do.

    Any ideas on those compile tools?
     
  5. Crimson

    Crimson L3: Member

    Messages:
    119
    Positive Ratings:
    1
    Paddy means have you tried unchecking the "Do not run the game after compiling" box so that it will run after compiling. Last I checked though there was a problem with that, atleast for TF2.
     
  6. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    I haven't used the CST tools, but I'm pretty sure they wouldn't work right until he has orange box versions because of the new version of the Source engine.
     
  7. Tobias Greenich

    Tobias Greenich L1: Registered

    Messages:
    15
    Positive Ratings:
    0
    Crimson, I left it unchecked, it was one of the things I toyed with before just calling it a night.

    Thanks for your help! I'll just work with it the way it is.