Got some newbie questions

Discussion in 'Mapping Questions & Discussion' started by RuninginCircles, Jun 5, 2008.

  1. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    Sorry if some of these have been asked before, I read the stickies and they didn't list any of my problems...

    Anyways, first of all in Hammer I used to be able to see stuff at great distance (a good football field away) now I can hardly see anything beyond 20 feet without it blacking out. Is there something I pushed by accident that made it do that or was it some kind of ninja patch valve did? :p

    My next biggest thing is lighting and boy am I having problems with it >.<

    I took a few pics with my map, I hope they describe it better than my words.
    I have an light_environment right next to he building circled in green by the wall, but it turns up black when I'm standing in this building. When I go out the door and step a few feet it goes right to its normal color. I'm really not sure why it would be doing that...I've tried everything I know to fix it =x
    [​IMG]

    lighting problem #2 (might be related, no clue) As you can see, these pictures were taken less than 1 foot away from each other, but the lighting is totally different. This makes absolutely no sense to me at all...
    [​IMG]
    [​IMG]

    ok, done with lighting for now, on to that bar on the bottom. Red is supposed to be attacking and blue defending. The capture points will change from blue to red just fine...but I have yet to find out how to make the cart red and the base icon go red. Is this something that can be changed in one of my entities somewhere or do I need to do something else?

    Alrighty, and last question: When I used to compile the map when it was really small I could run everything on normal. When it got bigger and more objects put into it and I tried to run it, vvis would freeze and I would have to end hammer and vvis in task manager. I later found out that if I ran VIS in Fast mode it would compile just fine. I've googled around and found nothing, so I was hoping someone here would know.

    Anyways, sorry for the big post but it would be a great help if I could get some of these issues worked out.

    Thanks all
     
  2. R3dRuM

    R3dRuM L6: Sharp Member

    Messages:
    303
    Positive Ratings:
    19
    2nd and 3rd pic: your using model textures

    For the vvis crash, check your log for errors, and/or let it run over night see if it still is taking long and if it finishes.
     
  3. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    What about using model textures? Does light affect models differently than normal textures?

    Hmm, I set it back to normal and it seems to do it fine now, strange that adding hundreds of new things would make it run fine....
     
  4. Nineaxis

    aa Nineaxis Quack Doctor

    Messages:
    1,767
    Positive Ratings:
    1,404
    Light affects models differently (I'm pretty sure), but that's not the issue. It's an error with actually putting a model texture on a brush. (I think :unsure: )

    So just make sure none of the textures you apply start with "models/" and instead start with "wood", "concrete", or whatever.
     
    • Thanks Thanks x 1
  5. bob+M|M+

    bob+M|M+ L6: Sharp Member

    Messages:
    348
    Positive Ratings:
    185
    you know light_environment has to be an entity, not a brush right? so it shouldn't be a visible brush in-game. also make sure you only have one light_environment per sealed area.

    you can get rid of the shadows under your traintrack props by going to the entity properties and disabling all the shadow features
     
  6. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    I fixed the lighting, now just need help with hammer not being able to view large distances and the bomb cart / home base showing as red instead of blue.
     
  7. slix00

    slix00 L1: Registered

    Messages:
    21
    Positive Ratings:
    1
    Bomb cart and etc cannot be red instead of blue.
     
  8. Ace

    Ace L3: Member

    Messages:
    112
    Positive Ratings:
    9
    As far as I know, you can put a model texture on a brush without a compile error, but it will loook very wrong (like your pics). This is because model textured have extra's built in (like UV mapping) meaning it will only look good if skinned on a specifically sized object (the exact size / shape of the model it is supposed to be on), so realistically they can only be used on the model they were made for.
     
  9. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    ...wtf? You mean valve didn't plan ahead and think that people might actually want payload maps where red attacks instead of blue? How retarded. =/
     
  10. bob+M|M+

    bob+M|M+ L6: Sharp Member

    Messages:
    348
    Positive Ratings:
    185
  11. Axii

    Axii L1: Registered

    Messages:
    47
    Positive Ratings:
    7
  12. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    Actually, I think the texture for the buidlings and models is EXACTLY the same.

    The UVW coords are stored on the model, not the texture.

    The 'MATERIALS' stored the data of how that tex will be lit.

    Model materials use vertex lighting, they have verts all over them that spreads the light out over them evenly. Brushes don't have all these extra verts so that material won't work. In the material file (FTM or whatever they are called) the very tp line dictates what lighting mode they will use.
    --------------------
    I've noticed alot of people are using the 'Blu defending' 'Red attacking' thing.

    At first I thought it might be cool but now I think it's a bad idea.

    First off, it doesn't change gameplay at all. You're either attacking or defending no matter what color you are.

    Second, alot of times when I play a map I think "I want to defend this time". So I choose red. But if the mapper changes it I get stuck attacking. That's gonna start to suck if you have to try and memorize every custom map that has reversed the roles and I'm sure it'll get to the point where it frustrates alot of players.
     
  13. R3dRuM

    R3dRuM L6: Sharp Member

    Messages:
    303
    Positive Ratings:
    19
    i get no thanks? pshh
     
  14. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    The reason I had red attacking and blue defending is because the story of the map. I see Blu as a more industrialized type, and have built a base inside a giant hillside and are mining up some strange material (Cap point 2) then shipping it underground to be refined or something, I havent decided.

    Basically with Blu having lots of cement buildings and such and red having more wood, I thought it would look better if the underground areas would look more realistic as cement rather than wood.

    Heck, even Counter-Strike has both teams attacking and defending. cs maps the CTs would attack, de maps the terrorists would attack. But back then you were stuck on a team unless you A. got auto-switched. or B. switched yourself (and as a result, usually got called a team stacker). In TF2, you switch attacking and defending the whole map...so really even though you feel like defending, you're going to be attacking shortly after the round is over anyways.

    Yeah, I saw those and actually downloaded the red one, but what I'm trying to get is the cart icon and home icon on the hud to turn red, I wasn't worried about the cart =x
     
  15. Nineaxis

    aa Nineaxis Quack Doctor

    Messages:
    1,767
    Positive Ratings:
    1,404
    As long as you stick to the TF2 theme, wood and dirt go next to each other. Just look at the decompiled official maps, see what Valve did. Try and conform to the standard of Blu attacking and Red defending. Or make the story fit to it.

    You might just want to use the team-neutral mining textures if it is mining in a hillside, and keep multi-color props skinned to Red (spotlights, barrels, etc.)

    Change the story. Red found it and are using their inefficient non-industrial techniques to mine it, and Blu found out, and want to capture it, knowing they can increase production by 300% with their mechanical innovations.
     
  16. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    Alrighty to update...I did change it to blue attack red defend, and changed a lot to the map. I'll get a new pic up later, a little pressed for time atm. Anyways, I've run into a new problem. When the time runs out instead of giving red the victory, TF2 crashes.

    On my team_round_timer entity I have the output
    "OnFinished - game_round_win - RoundWin"
    The team on the game_round_win is set to red.

    What would make the game crash like that? I don't understand =(
     
  17. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    /bump?
     
  18. DJive

    aa DJive Cake or Death?

    Messages:
    1,466
    Positive Ratings:
    736
    ^ please dont bump a topic that isn't even 6 posts down =)
     
  19. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    sorry =( just wanted to get this fixed so I could show my friends tomorrow without having to crash every time the map ends >.<
     
  20. RuninginCircles

    RuninginCircles L1: Registered

    Messages:
    18
    Positive Ratings:
    1
    Sorry to bring this up again, but I've searched everywhere I can think of. Every time the timer ends, the game crashes. I have it set up identical to goldrush's team_round_timer and game_round_win, but it still keeps on crashing.

    Any help? please? :(