Buy Elder Scrolls Online: Greymoor for PC at Green Man Gaming

Elevator Problem

Discussion in 'Mapping Questions & Discussion' started by TMB, Jul 24, 2016.

  1. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    79
    To do what Maccy is saying:

    Step 1: Click on the orange brush that you want to make your elevator out of. Press Ctrl-T, and change the "func_detail" to a "func_door".

    Step 2: On the func_door, change the open direction to "down", change the name to "elevator", and change the Speed to "20" (or something like that)

    Step 3: Put one of your path_tracks above the elevator, and the next path track where the elevator will stop.

    Step 4: Open the path_track above the elevator, and set the "Parent" to "elevator".

    Step 5: On the path_track above the elevator, add two outputs. The first output is "OnPass" - "sspl_train" (or whatever the func_tracktrain is named) - "SetSpeedReal" - 20 (or whatever you set the speed at on the func_door). The second output is "OnPass" - "elevator" - "Open".

    Step 6: Open the path_track at the end of the elevator and add one output. "OnPass" - "sspl_train (or whatever the func_tracktrain is named) - "SetSpeed" - 0.

    Someone let me know if I botched this, but I think this is all you have to do.

    Edit: you probably have to adjust the "lip" on the func_door to make it go all the way down. You'll need a negative number, probably around -64 from the looks of your screenshot.
     
  2. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    Ok, i get lost in step 5... i dont understand it... i have a solution much easier than try understand that, but you wont like it, can you make it and pass to me for dropbox?
     
  3. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    79
    Ok, here are Steps 5 and 6 broken down:

    - Open up the path_track that you put at the top of the elevator.

    - Click the "Outputs" tab

    - Click "Add..."

    - In the box next to "My output named", put "OnPass"

    - In the box next to "Target entities named", put "sspl_train" (or whatever the func_tracktrian is named)

    - In the box next to "Via this Input", put "SetSpeedReal"

    - In the box next to "With a paramter override of" , put "20"

    - Click "Add..." again

    - In the box next to "My output named", put "OnPass"

    - In the box next to "Target entities named", put "elevator"

    - In the box next to "Via this Input", put "Open"

    - Click Apply, then close that path_track.

    - Open the path track at the bottom of the elevator

    - Click the "Outputs" tab

    - Click "Add..."

    - In the box next to "My output named", put "OnPass"

    - In the box next to "Target entities named", put "sspl_train" (or whatever the func_tracktrian is named)

    - In the box next to "Via this Input", put "SetSpeed"

    - In the box next to "With a paramter override of" , put "0"

    - Click apply
     
  4. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    Emmm, why setspeedreal and setspeed are in red?
     
  5. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    79
    The name in the "Target entities named" box needs to be the name of the func_tracktrain. If you are using the ABS game mode prefab for single stage payload, it will be named sspl_train. Otherwise, it will be named something else. Are you using the ABS game mode prefabs? If so, which one are you using?
     
  6. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    Im using ABS prefab and im using PLR 1 Stage
     
  7. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,113
    Positive Ratings:
    6,481
    Hi TMB, please don't just comment ellipses to bump your thread. A reasonable time to bump a thread is a day or more, not every half an hour.
     
  8. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    79
    Okay, so you need to use "ssplr_blu_train" for the blu cart, and "ssplr_red_train" for the red cart, instead of "sspl_train".
     
  9. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    yes, but i dont have time the jam will be end in 21 hr and i didnt finished yet!
     
  10. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    Tha wasn fail, look the image
     
  11. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    79
    Are you sure you're using the single stage payload race prefab? Try "plr_blu_train". The reason SetSpeedReal is red is because the name in "Target entities" is wrong.

    Edit: nevermind, I see the problem. You have "ssplr_blu_cart", not "ssplr_blu_train". Change that, and it should be fixed.
     
  12. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,113
    Positive Ratings:
    6,481
    Its okay - the entry still counts even if it's not finished! If this is slowing you down, i'd suggest just making a ramp instead.
     
  13. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    No, must be perfect
     
    • Respectfully Disagree Respectfully Disagree x 3
  14. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    So, now should work?
     
  15. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    79
    It should, as long as nothing is red. Try it out and see. Remember to change the "Lip" on the func_door to a negative number around -64, so the elevator goes down far enough. You'll have to experiment to see which number is right.
     
  16. Crowbar

    aa Crowbar Live demonstration of the hairy ball theorem

    Messages:
    1,458
    Positive Ratings:
    1,272
    I honestly see a reason for that, the current thread avalanche because of the jam. Though half an hour is a bit too often yeah.
     
    • Agree Agree x 1
  17. TMB

    TMB Banned

    Messages:
    826
    Positive Ratings:
    287
    Ok, doesnt work, but i dont have time so i have to make a ramp...

    Edit: Ok, now the cart go back even when go down the ramp!
     
    Last edited: Jul 25, 2016
  18. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    79
    Just delete all of the things in the Outputs tab of the path_tracks by where the elevator was to make them back into normal path_tracks. If you want the cart to roll down the hill automatically, then open the path_track on top of the ramp, click the Flags tab, and check the "downhill zone" box.
     
Buy Elder Scrolls Online: Greymoor for PC at Green Man Gaming