Compiling error

Discussion in 'Mapping Questions & Discussion' started by Draser, Sep 10, 2010.

  1. Draser

    Draser L3: Member

    Messages:
    144
    Positive Ratings:
    12
    Does anybody know the reason why my map says this when compiling?
     
  2. Tapp

    Tapp L10: Glamorous Member

    Messages:
    776
    Positive Ratings:
    211
  3. Draser

    Draser L3: Member

    Messages:
    144
    Positive Ratings:
    12
    Yeah, that wasn't the problem. The big problem is the error that says "The system cannot find the file specified." In which case it asks me if i want to continue, and if i click yes the compilation is instantly done, and it opens tf2, but the map in't there, and no bsp is made.
    If i click no. obviously the compiling process just shuts off. Its only for this map though. and im not entirely sure how you check for leaks, but i don't think i have one.

    As for the camera thing. i got rid of it and it works now, but i would like to still have a 3d skybox. -.-
     
  4. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    For me, I had that issue when I had my sky camera inside a brush, or there was an entity or 2 outside of the map, in the 'void'

    When you go to compile, click "Do not run game" at the bottom, let it finish, when it is done, copy it to the clipboard and paste it here: http://www.interlopers.net/index.php?page=errors

    This will help you determine any issues.
     
  5. Huckle

    Huckle L4: Comfortable Member

    Messages:
    150
    Positive Ratings:
    87
    The problem is actually that you have a leak (or similar error), which is causing "The system cannot find the file specified.". It's not the other way around. The vis file cannot be found because vvis is not running at all and it's not running because you have a leak, forcing vbsp to finish prematurely.

    Always fix your problems from the top down, a leak will give you tons of areaportal leaks, occluder straddles etc.
     
  6. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Leaks don't crash the compiler. Your sky_camera was stuck in a solid object.
     
  7. Draser

    Draser L3: Member

    Messages:
    144
    Positive Ratings:
    12
    Well, thats just it, i made sure that the texture i had around there was a couple hammer units away after you guys told me about the sky_camera being stuck inside a texture, and it still didn't work.

    Could the fact that the same texture that was near the sky_camera, also stuck through the tools/skybox texture thing make it mess up?
     
  8. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Are you sure it wasn't stuck in a brush?
     
  9. Tapp

    Tapp L10: Glamorous Member

    Messages:
    776
    Positive Ratings:
    211
    Try refreshing the SDK content and running tf2, that might fix it. Otherwise, I really assumed it was a problem with your sky_camera. Go into entity report, and double-check you don't have another one you accidentally made (or left in).
     
  10. Draser

    Draser L3: Member

    Messages:
    144
    Positive Ratings:
    12
    Well, for now, it DOES work....but no 3d skybox, oh well. I guess ill figure out the 3D skybox thing near the end.