buildcubemaps error

Discussion in 'Mapping Questions & Discussion' started by OlafK, Dec 12, 2009.

  1. OlafK

    OlafK L2: Junior Member

    Messages:
    55
    Positive Ratings:
    15
    Allrighty, I've thrown some of env_cubemaps to my first map for some nice reflections. Launching game, sv_cheats 1, mat_specular 0, map mymapname, buildcubemaps, game crashes :O If I understand correctly, some random images should flicker, but nothing such happens, so I guess the game didn't even start to build them. The error says something about cannot reading the memory adress, but I'm 99,9% sure that my RAM is fine and I have whole 1,75 gigs of it. I'm playing with Quantum's Ultra High FPS config, because everything else on this PC is crappy (it's 5 years old, but with this config TF2 is running ~25 FPS), could this be the source of problem?
     
  2. KarmaPolice

    KarmaPolice L3: Member

    Messages:
    108
    Positive Ratings:
    52
    My game is crashing when I try to build cubemaps too, which is strange, because it's never happened before.
     
  3. OlafK

    OlafK L2: Junior Member

    Messages:
    55
    Positive Ratings:
    15
    Okay, just don't blame me and my map for not having cubemaps built when I'll release an alpha of it.
     
  4. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    I can't read...... whatever language that message is in.

    There's probably something wrong brush or entity wise in your map. Try making a really small test map (a hollowed out brush if you will), throw in a light source and an env_cubemap, and see what happens.

    If that builds fine, then there's something you've done in your actual map that Hammer doesn't like
     
  5. Daedryon

    Daedryon L3: Member

    Messages:
    134
    Positive Ratings:
    3
    See, I was having a pink checkerboard pattern problem on shiny things like weapons, in my map.

    All I did was add env_cubemap entities. I didn't use any specular or buildcubemaps commands, and when I tested my map the problem disappeared.

    I don't think you have to do build cubemaps unless your maps pink checkerboard problem is really severe.

    How big is your problem? Are there faint textures on shiny surfaces like the Sniper's Jarate? Or is a big problem?
     
  6. OlafK

    OlafK L2: Junior Member

    Messages:
    55
    Positive Ratings:
    15
    Okey, on the "small test map" building cubemaps also failed, so I guess it's something with my TF2.

    Well, I personally have reflections always off (or TF2 wouldn't run at reasonable speed or even at all), but I've put reflective (I guess) floor in the bases. Also, trying to set mat_specular to 1 also makes my game crash. I feel like these problems are related and because of my crappy graphics card.
     
  7. OlafK

    OlafK L2: Junior Member

    Messages:
    55
    Positive Ratings:
    15
    Sorry for bumping, but I've found a solution. My PC is so crappy that I have to run TF2 at 640x480, or it will run slower than 20FPS. I've turned 800x600 just for building cubemaps, and it worked. Yay.