• Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

mat_mot0

L2: Junior Member
Feb 11, 2018
85
I had a error with my map that would not compile the rest of my progress into the game. I checked it on Interloper.net and I don't know what "brush 5955: floatplane: bad normal side 1 texture: tools/toolsnodraw" means. I'm very knew to the mapping community and mapping in general and any help would be greatly appreciated. Thank you.
Compile log:
** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\somewhere.vmf"

Valve Software - vbsp.exe (Oct 14 2017)
4 threads
materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\somewhere.vmf
Brush 5955: FloatPlane: bad normal
Side 1
Texture: TOOLS/TOOLSNODRAW


** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\somewhere"

Valve Software - vvis.exe (Oct 14 2017)
4 threads
reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\somewhere.bsp
reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\somewhere.prt
LoadPortals: couldn't read c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\somewhere.prt


** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\somewhere"

Valve Software - vrad.exe SSE (Oct 14 2017)

Valve Radiosity Simulator
4 threads
[Reading texlights from 'lights.rad']
unknown light specifier type - lights

[56 texlights parsed from 'lights.rad']

Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\somewhere.bsp
Setting up ray-trace acceleration structure... Done (0.08 seconds)
1153 faces
298634 square feet [43003416.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
1153 patches before subdivision
33419 patches after subdivision
0 direct lights
BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (0)
BuildVisLeafs: 0...1...2...3...4...5...6...7...8...9...10 (1)
transfers 3134794, max 388
transfer lists: 23.9 megs
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #1 added RGB(0, 0, 0)
Build Patch/Sample Hash Table(s).....Done<0.0063 sec>
FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (0)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (1)
Writing leaf ambient...done
Ready to Finish

Object names Objects/Maxobjs Memory / Maxmem Fullness
------------ --------------- --------------- --------
models 5/1024 240/49152 ( 0.5%)
brushes 243/8192 2916/98304 ( 3.0%)
brushsides 1797/65536 14376/524288 ( 2.7%)
planes 1214/65536 24280/1310720 ( 1.9%)
vertexes 1746/65536 20952/786432 ( 2.7%)
nodes 600/65536 19200/2097152 ( 0.9%)
texinfos 63/12288 4536/884736 ( 0.5%)
texdata 26/2048 832/65536 ( 1.3%)
dispinfos 0/0 0/0 ( 0.0%)
disp_verts 0/0 0/0 ( 0.0%)
disp_tris 0/0 0/0 ( 0.0%)
disp_lmsamples 0/0 0/0 ( 0.0%)
faces 1153/65536 64568/3670016 ( 1.8%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 605/65536 33880/3670016 ( 0.9%)
leaves 606/65536 19392/2097152 ( 0.9%)
leaffaces 1348/65536 2696/131072 ( 2.1%)
leafbrushes 419/65536 838/131072 ( 0.6%)
areas 2/256 16/2048 ( 0.8%)
surfedges 8043/512000 32172/2048000 ( 1.6%)
edges 4583/256000 18332/1024000 ( 1.8%)
LDR worldlights 0/8192 0/720896 ( 0.0%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
leafwaterdata 0/32768 0/393216 ( 0.0%)
waterstrips 99/32768 990/327680 ( 0.3%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 1614/65536 3228/131072 ( 2.5%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 0/512 0/180224 ( 0.0%)
LDR lightdata [variable] 938160/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 13806/16777216 ( 0.1%)
entdata [variable] 3936/393216 ( 1.0%)
LDR ambient table 606/65536 2424/262144 ( 0.9%)
HDR ambient table 606/65536 2424/262144 ( 0.9%)
LDR leaf ambient 297/65536 8316/1835008 ( 0.5%)
HDR leaf ambient 606/65536 16968/1835008 ( 0.9%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/1716 ( 0.1%)
pakfile [variable] 842/0 ( 0.0%)
physics [variable] 91947/4194304 ( 2.2%)
physics terrain [variable] 2/1048576 ( 0.0%)

Level flags = 0

Total triangle count: 3311
Writing c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\somewhere.bsp
2 seconds elapsed

** Executing...
** Command: Copy File
** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\somewhere.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\somewhere.bsp"


** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\hl2.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -windowed -noborder -w 1920 -h 1080 -novid +map "somewhere" -steam
 

Vel0city

func_fish
aa
Dec 6, 2014
1,947
You have a brush that is invalid. Read on the issue here: https://developer.valvesoftware.com/wiki/Invalid_Brushes The texture it gives you is the texture that's applied to the face of that invalid brush. Alternatively, use Alt+P in Hammer to get the error checker, it'll tell you that you have a bad brush. You can then fix it via that menu or go the the conflicting brush yourself and fix it there.
 

henke37

aa
Sep 23, 2011
2,075
Use the View->Go to Brush Number command to find the offending brush.