1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

All map entities have disappeared!

Discussion in 'Mapping Questions & Discussion' started by LoftyTheMetroid, May 22, 2010.

  1. LoftyTheMetroid

    LoftyTheMetroid L1: Registered

    Messages:
    16
    Positive Ratings:
    0
    Okay, so I'm kind of in a panic mode right now, and I'm wondering if anybody might have a solution for me.

    So, within the last two hours, I just showed off some additions to my map to my friend, I closed Hammer and the Source SDK (without saving any files, I didn't want to save my changes), and then we played L4D2 for about an hour.

    Afterward (within the last half hour), I opened the same file again, and now all of my entities are missing from my map! My objects, doors, lights, triggers... everything just disappeared, and all that's left is my brushwork. Hammer isn't missing any of the actual entity files, as I can instantiate new entities of any kind -- it's only my previously created entities that are missing.

    ...Is there anything I can do? :(
     
  2. Pooluke41

    Pooluke41 L5: Dapper Member

    Messages:
    203
    Positive Ratings:
    30
    Checked your Visgroups?
     
  3. LoftyTheMetroid

    LoftyTheMetroid L1: Registered

    Messages:
    16
    Positive Ratings:
    0
    I've enabled every Visgroup, and they're not showing up...

    They're just... for seemingly no reason... gone....
     
  4. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,920
    find the <mapname>.vmx in your mapsrc folder, rename it .vmf and open it in hammer.

    If all your stuff is there you're saved. if it's not you've got some serious issues!
     
    • Thanks Thanks x 2
  5. LoftyTheMetroid

    LoftyTheMetroid L1: Registered

    Messages:
    16
    Positive Ratings:
    0
    That did it! Thank you thank you thank you!!
     
  6. Jesmonda

    Jesmonda L1: Registered

    Messages:
    20
    Positive Ratings:
    8
    thanks Youme, had the same problem, however i'm unsure where to go from here, now that i've found all my stuff again, i've Copy & Pasted it all back into the original map file, however upon reading this:

    " In some cases it may be necessary to roll back to the VMX file, simply delete or rename the VMF and then change the VMX extension to VMF"

    i read this at the Valve Wiki on vmx, i take it then it's now a matter of deleting the original map file and changing the vmx extension to a vmf, in which case a new vmx of that file will appear upon save? going to give it a try later.
     
  7. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,538
    Yes. The VMX is the save before the current one.
     
  8. Smileytopin

    Smileytopin L1: Registered

    Messages:
    40
    Positive Ratings:
    17
    I need help, I have the same error but have no .vmx...
     
  9. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,115
    Positive Ratings:
    6,437
    Try finding an autosave- your Autosave folder might be somewhere fairly strange, but if you can find it and open your most recent autosaved vmf, that might help.
     
  10. Snowbat

    Snowbat L4: Comfortable Member

    Messages:
    165
    Positive Ratings:
    64
    Not sure if you still need help, but if you wonder where Hammer saves your autosave files, check the options in Hammer: Options--> General Tab--> Autosave Directory