Access Denied

Discussion in 'Mapping Questions & Discussion' started by Kronack, Sep 29, 2010.

  1. Kronack

    Kronack L2: Junior Member

    Messages:
    74
    Positive Ratings:
    4
    I for some reason just started getting this error for no reason.


    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\myname\sourcesdk_content\tf\mapsrc\cp_outlet_a2.bsp" "c:\program files (x86)\steam\steamapps\myname\team fortress 2\tf\maps\cp_outlet_a2.bsp"

    The command failed. Windows reported the error:
    "Access is denied."

    What do I do here? I compiled a map and it worked fine, then tried to compile just the bsp after tweaking it to check for leaks, and it gives me that. Everything seems to be running and compiling fine even on a full compile.
     
  2. nik

    nik L12: Fabulous Member

    Messages:
    987
    Positive Ratings:
    246
    run it in admin mode?
    try moving it to somewhere else when you compile it?

    also you said 'for some reason' then you said 'for no reason' WHAT DO YOU MEAN?
     
    • Thanks Thanks x 1
  3. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
    I had this problem once. I deleted some old bsp and relaunched Hammer. I think that did it. Maybe I renamed the vmf too. Don't know. Try that?
     
    • Thanks Thanks x 1
  4. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    I didn't know you could compile the bsp. Or do you mean compiled the vmf into a bsp?

    Posting the compile log wouldn't hurt either just to triple check.

    edit: If you're running Win7, sometimes it will tell you the vbsp stopped working even though all it really did was move on to vrad (or vvis whichever is second).
     
    • Thanks Thanks x 1
  5. Kronack

    Kronack L2: Junior Member

    Messages:
    74
    Positive Ratings:
    4
    Strange, seems to be fixed, the renaming and deleting the old bsp fixed it, thanks all! Now if only I could figure out why the hell my spawn points are unclear to the console.
     
  6. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    They have to be a few units away from everything else. So not directly on the ground and not directly against a wall. (or clipping through any of them obviously :p)
     
  7. Kronack

    Kronack L2: Junior Member

    Messages:
    74
    Positive Ratings:
    4
    It seems all the unclear points are in one spawn, made sure they are all 16 units away from everything else and still messed up for some reason :\
    May gonna just try remaking them
     
  8. nik

    nik L12: Fabulous Member

    Messages:
    987
    Positive Ratings:
    246
    just redo them all, ensure they are a little off the ground!
     
    • Thanks Thanks x 1
  9. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    map_showspawnpoints will show you just what is being blocked. (including ones you are standing in, so move away first)
     
    • Thanks Thanks x 1
  10. Kronack

    Kronack L2: Junior Member

    Messages:
    74
    Positive Ratings:
    4
    fixed it, thanks all :)