3D Skybox has odd shadows/lighting

Discussion in 'Mapping Questions & Discussion' started by Angry_Ed, May 11, 2011.

  1. Angry_Ed

    Angry_Ed L1: Registered

    Messages:
    41
    Positive Ratings:
    29
    I looked around to see if anybody had encountered this problem before but after much searching both here and elsewhere on the Internet I couldn't quite find what I'm experiencing currently. For whatever reason, the shadows in my 3D skybox area are quite odd looking; frequently being blocky or jagged. In addition, the lighting in the 3D skybox seems to be producing odd results with the terrain, making it clear where displacement seams are located.

    [​IMG]

    The only thing I can think of that might be causing this is that I don't recall sewing the displacements I was using for the skybox together, but other than that I'm out of ideas. I believe my 3D skybox has everything it requires (including a light_environment), so I'm still not sure what could be causing all this. Any help is appreciated.
     
  2. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    I don't see your issue, you could try and adjust the lightmap on the texture, that might help your shadows.

    Also, if this is a TF2 map, preferably use TF2 textures, those white buildings (and maybe brick ones) aren't TF2.
     
  3. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    I don't see your issue, you could try and adjust the lightmap on the texture, that might help your shadows.

    Also, if this is a TF2 map, preferably use TF2 textures, those white buildings (and maybe brick ones) aren't TF2.
     
  4. Angry_Ed

    Angry_Ed L1: Registered

    Messages:
    41
    Positive Ratings:
    29
    I just double-checked and according to the model viewer those buildings are from TF2. In fact they were used in the 3D Skybox for Well.
     
    Last edited: May 12, 2011
  5. honeymustard

    honeymustard L9: Fashionable Member

    Messages:
    698
    Positive Ratings:
    273
    You have a light_environment inside the 3d skybox? Take that out.
     
  6. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Oh, I would've sworn they were HL2. Sorry about that.

    If your issue isn't fixed, try honeymustards solution, that may cause it too.
     
  7. honeymustard

    honeymustard L9: Fashionable Member

    Messages:
    698
    Positive Ratings:
    273
    Well I don't know if that'll cause problems, but you only need one in the map.
     
  8. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    251
    Any light without the env_ prefix shouldn't be in the skybox. It'll look all wrong.

    The light_environment in the map also affects the skybox so really, you only need one light_env.
     
  9. Angry_Ed

    Angry_Ed L1: Registered

    Messages:
    41
    Positive Ratings:
    29
    Well I went in and removed the duplicate light_env, and changed the lightmaps on all my skybox displacements from 16 units/luxel to 32. It doesn't seem to have done much though. Here's a better screenshot illustrating my problem

    [​IMG]

    Basically instead of a nice smooth gradient on the shadow cast by the building it's very rough, and you can easily see where the shadow's intensity changes instead of it falling away gradually.
     
  10. KingOfSandvich

    KingOfSandvich L1: Registered

    Messages:
    26
    Positive Ratings:
    10
    Did you make the building a dynamic prop instead of a static one? Dynamic props have jagged and dark shadows that are rendered in real time. Static props have smoother, precompiled shadows. Make sure that building prop is a prop_static.
     
  11. Angry_Ed

    Angry_Ed L1: Registered

    Messages:
    41
    Positive Ratings:
    29
    Every prop in the 3d skybox is a static prop
     
  12. Empyre

    Empyre L6: Sharp Member

    Messages:
    295
    Positive Ratings:
    145
    Maybe decreasing the units per luxel instead of increasing it will help? Maybe it's worth a try, even if I don't completely know what I'm talking about. Also, maybe try a shadow controller entity.
     
  13. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Increasing the lightmap scale will give rougher shadows; decrease it to 8 or so in the 3d skybox to get sharper shadows.
     
  14. Angry_Ed

    Angry_Ed L1: Registered

    Messages:
    41
    Positive Ratings:
    29
    Well I thought my problem was more that the shadows are too sharp, or at least when I was looking at the lightmap comparisons the gradient was more defined and the shadows were a lot more diffused. Also when i looked at other lightmap scales for other skyboxes they seemed to have the scale set to 32 or 64 units/luxel.

    Course at this point I might as well try everything so I'll try decreasing the lightmap scale and see what happens.
     
  15. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Turn off shadows on the buildings, problem solved :p
     
  16. Angry_Ed

    Angry_Ed L1: Registered

    Messages:
    41
    Positive Ratings:
    29
    I tested that out by disabling shadows on one side of the 3d skybox and it actually looks a lot better. A bit weird when there are no shadows being cast by the buildings, but I'll take weird over ugly.