Weird Vis issue.

Discussion in 'Mapping Questions & Discussion' started by Asmotron, Jul 29, 2010.

  1. Asmotron

    Asmotron L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    So I'm building a 2fort clone (yes, insert groans here) and I'm having an issue with vis in one of my underwater tunnels that I just can't get to go away for the life of me.

    At first when I built this section it was copy and pasted from the red half of the map (I built the red half and then copied/pasted/flipped it). Since then I have rebuilt this entire tunnel system, rebuilt the water in it, etc. The problem refuses to go away, but does not exist in the red half of the map in the same place.

    Here is what happens:

    [​IMG]

    From the bottom of the tunnel looking up. You can see the ceiling of the room above, and the bridge in the outside in the center of the map.

    Now, if you move over just a tick toward the vertical tunnel and enter its visleaf goes back to this:

    [​IMG]

    The bug remains if you would move back further into the horizontal tunnel.

    I just can't figure this out. I've tried using a func_viscluster (without crossing the water surface, of course) to tell it that the two leaves can see each other. No dice. I haven't played with hint brushing in here as I don't know how it would really help...

    Lastly, this is what the portal file looks like in hammer:

    [​IMG]

    There is a small leaf between the horizontal and vertical tunnels, and one leaf for the horizontal tunnel.

    Any help would be greatly appreciated!
     
  2. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    try func_areaportal.
     
  3. Asmotron

    Asmotron L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    I'll have to give this a shot if I have time tonight before I head out of town.

    I thought of this but wasn't sure due to the fact that the walls are vanishing independent of a visleaf and of any actual brushes in that area.

    Thanks, and I'll see what happens! :)
     
  4. Asmotron

    Asmotron L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Area portal's didn't seem to help. I tried putting them in a couple different spots, the walls still vanish.