Weird lighting artifacts on displacements?

Discussion in 'Mapping Questions & Discussion' started by alvaol62, Feb 17, 2013.

  1. alvaol62

    alvaol62 L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    I have made a lot of displacements in my map. However the lighting is not uniform on them:

    http://steamcommunity.com/id/alvaol62/screenshots/

    (Latest three screenshots)

    You can see that the rocks on the right bottom side of the third picture are darker than they should be. :confused:

    Any help is greatly appreciated. :(
     
    Last edited: Feb 17, 2013
  2. henke37

    aa henke37

    Messages:
    1,955
    Positive Ratings:
    465
    Links are broken.
     
    • Thanks Thanks x 1
  3. alvaol62

    alvaol62 L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Linked my steam page
     
  4. Tarry H Sruman

    Tarry H Sruman Large Orphanage Proprietor

    Messages:
    871
    Positive Ratings:
    1,010
    In an update a while ago Valve essentially broke displacement lighting. Now there are basically irreparable splotches on displacements in most maps, including Doomsday.

    This, however, doesn't look like that and I don't know what's wrong with it.
     
  5. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,692
    When you made the displacements, did you also select the faces between the brushes (the faces that share a plane)? If so, apply displacements only to the sides facing out - if you have disps touching at a corner, they will be, by default, smoothgrouped together, resulting in weird shadow bleeding.