Weird Display Bug in Hammer for Reflective Surfaces

Discussion in 'Mapping Questions & Discussion' started by Wormaldson, Nov 27, 2010.

  1. Wormaldson

    Wormaldson L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    So I only just started learing to use Hammer a few days ago, and I've run into this odd problem. I haven't been messing around with texture files or anything like that, so I doubt it's anything I've done, but any reflective texture I try to view in hammer shows up completely white, with the white glare sort of "climbing" up the walls and such. I looked around on the internet for a bit, but couldn't find anything about it.

    Screenshots:

    [​IMG]

    [​IMG]

    [​IMG]

    Anyone know anything about this?
     
  2. PL-7764

    PL-7764 L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    84
    That "floor_tile_reflect" texture you're using doesn't work right, period. I'm not sure what it is, but I don't think it's meant for brush surfaces by itself. You'll have to use something else.
     
  3. Wormaldson

    Wormaldson L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    Ah, righto. Thanks for the info sir, I was afraid there was something wrong with my SDK.
     
  4. lana

    aa lana Currently On: ?????

    Messages:
    3,077
    Positive Ratings:
    1,389
    Actually, I'm pretty sure something is wrong. Can we have some more information, like your graphics card manufacturer and the current version of DirectX you're running?
     
  5. Wormaldson

    Wormaldson L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    My graphics card is a Nvidia GeForce 9800 GTX+ and I'm using DirectX 11. And I've got (or at least, close to) the latest drivers for the graphics card. Any ideas?
     
  6. keithgarry

    keithgarry L2: Junior Member

    Messages:
    59
    Positive Ratings:
    8
    Nothing is wrong. floor_tile_reflect is an effect brush. It uses a water shader to imitate reflectivity. Make it 1 unit tall, put it 1 unit above your normal floor and cover all the areas that should look reflective. Put a cube map in your level, set a brush in the properties window, and compile with all options on normal. You should get something like this:

    [​IMG]

    Treat the texture as if it were a water texture. Don't cut it make sure to nodraw it.