VMF to SMD model folder

Discussion in 'Mapping Questions & Discussion' started by KaidemonLP, Apr 12, 2017.

  1. KaidemonLP

    KaidemonLP L4: Comfortable Member

    Messages:
    198
    Positive Ratings:
    33
    So im making a huge map so the brush number is over the limit. After some research i found a prgram for this
    its called VTF to SMD. My only problem is, I dont know where it stores the models. Does anyone know?
     
  2. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,441
    Positive Ratings:
    1,196
    It stores the models where you tell it - the SMD appears in the same folder as VMF, and is called like it.
     
  3. KaidemonLP

    KaidemonLP L4: Comfortable Member

    Messages:
    198
    Positive Ratings:
    33
    Thanks.
     
  4. KaidemonLP

    KaidemonLP L4: Comfortable Member

    Messages:
    198
    Positive Ratings:
    33
    For some reason the model is invisible. It has colisions but its invisible. Here is the qc


    $ModelName "props\hightower.mdl"

    $StaticProp

    $BodyGroup "Body"
    {
    studio "props.smd"
    }


    $SurfaceProp "wood"

    $Contents "solid"

    $MaxEyeDeflection 90

    $CDMaterials "metal"
    $CDMaterials "wood"
    $CDMaterials "tools"
    $CDMaterials "patterns\2fort"

    $TextureGroup "skinfamilies"
    {
    { "wall019" "wall011e" "wall011" "wall020b" "wood_wall006" "wood_bridge001" "wood_beam03" "grain_elevator_facade_14a" "wood_wall002b.vmt" }
    }

    $CBox 0 0 0 0 0 0

    $BBox -20.055 -179.894 -0.25 117.975 120.968 45.385


    $Sequence "idle" {
    "anims\props_skeletonAction.smd"
    activity "act_idle" 1
    fadein 0.2
    fadeout 0.2
    fps 30
    }
     
  5. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,882
    Positive Ratings:
    5,123
    I don't think you can have multiple lines of $CDmaterials, latter ones probably override the former.

    Try putting them in the same one such as $CDmaterials "metal" "wood" "tools" "patterns\2fort"
     
  6. KaidemonLP

    KaidemonLP L4: Comfortable Member

    Messages:
    198
    Positive Ratings:
    33
    I used multiple cd materials on other models. In fact i use it in almost every single model i made. Also hlmv shows that all the materials loaded.
    But this give me a idea. I might have forgten to add the $CDMaterials " ", il try that.
    EDIT: Nope still nothing.
     
    Last edited: Apr 13, 2017
  7. KaidemonLP

    KaidemonLP L4: Comfortable Member

    Messages:
    198
    Positive Ratings:
    33
    Ok i think i know why it desnt show up. The VMTs are broken.