Ugly shadows are ugly

Discussion in 'Mapping Questions & Discussion' started by Ost, Mar 6, 2010.

  1. Ost

    Ost L2: Junior Member

    Messages:
    61
    Positive Ratings:
    32
    Sup guys. Newbie mapper here. Just did a full compile of my map, and I have a problem.

    Fugly shadows.

    [​IMG]

    Every single shadow looks like that. The ceilings of my map, which is entirely indoor, are just a horrible black mess.

    It's not a problem with my ingame settings, and everything looks fine to me in Hammer. I'm a noob, however, so it's most likley a screw up on my part. Instead of going through every single entity and randomly changing settings for three hours, I decided to ask here instead.

    Halp pl0x?
     
  2. martijntje

    martijntje L8: Fancy Shmancy Member

    Messages:
    539
    Positive Ratings:
    168
    shadows that go towards pitch-black are always ugly. Simple add another light.
     
  3. Ost

    Ost L2: Junior Member

    Messages:
    61
    Positive Ratings:
    32
    I'm using Ravidge's Lighting Library for easy copypasta lighting, however I was unaware that it wasn't a complete solution and I had to add additional lights.

    Sneaky edit:

    Hey, guess what? Shadows are still ugly - they're just another shape now.

    [​IMG]
     
    Last edited: Mar 6, 2010
  4. Dustoxx

    Dustoxx L6: Sharp Member

    Messages:
    304
    Positive Ratings:
    40
    you got a leak, mate. well, it looks like you have :p

    map>load pointfile and follow the red line ;)
     
    • Thanks Thanks x 1
  5. Ost

    Ost L2: Junior Member

    Messages:
    61
    Positive Ratings:
    32
    D:

    I had no idea leaks could screw with shadows - thought they only caused general fuck-updness and performance issues.

    Thank you very much for the help, good sir.
     
  6. honeymustard

    honeymustard L9: Fashionable Member

    Messages:
    698
    Positive Ratings:
    273
    Check the compile log when you've finished compiling, it'll tell you if you have a leak :)
     
  7. martijntje

    martijntje L8: Fancy Shmancy Member

    Messages:
    539
    Positive Ratings:
    168
    normally "light bounces of walls several times", when you have a leak the light doesnt bounce off and faces are only lighted once.

    the other thing could be that your model is going through the ceiling ,that always causes nasty shadows. pick another model, lower your model or disable shadows on the model .I would suggest the first as I am quite sure that model comes in quite some variants of different height.
     
  8. Ost

    Ost L2: Junior Member

    Messages:
    61
    Positive Ratings:
    32
    Problem is solved now. The map had several leaks because of my horrible use of func_detail in the wrong places.
     
  9. XFunc_CaRteR

    XFunc_CaRteR L5: Dapper Member

    Messages:
    248
    Positive Ratings:
    17
  10. XFunc_CaRteR

    XFunc_CaRteR L5: Dapper Member

    Messages:
    248
    Positive Ratings:
    17
  11. Remnic

    Remnic L2: Junior Member

    Messages:
    95
    Positive Ratings:
    16
    This is a problem newcomers at Source mappers tend to make. Always remember that func_detail objects are not to be used to block visibility. In this case, seal leaks behind func_detail objects that might intersect with the void by using nodraw brushes. Otherwise, move the func_detail objects that are causing the leaks back to the world and rebuild them.