Textures not showing on func_respawnroomvisualizer??

Discussion in 'Mapping Questions & Discussion' started by Riever, Aug 8, 2012.

  1. Riever

    Riever L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    Could someone suggest why I cannot get the noentry overlay to show on my func_respawnroomvisualizer's? They are set to the correct spawn rooms, they stop the enemy, but the texture is just not showing. I tried copying some from Valve maps (which work) to mine and they still don't show the noentry texture.

    The texture shows fine in Hammer, just not in the game. :confused:
     
  2. ForbiddenDonut

    aa ForbiddenDonut

    Messages:
    391
    Positive Ratings:
    403
    Make sure these are true:

    1. The texture is applied to the brush face as a texture, not as an overlay.

    2. You are on the opposite team of the visualizer's respawn room setting (ex. BLU if it's blocking a RED respawn room).

    Does the brush itself work? Does it block enemy players? Is it only the texture that is showing up or is the entire entity not working?
     
    • Thanks Thanks x 1
  3. Riever

    Riever L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    Hi,

    Thanks for the heads up on the overlay - how do I make sure? I hit ctril-a, picked the texture and then right-clicked on the face to apply it. Basically the same way as I've applid all the textures. The entity works and blocks the opposing team - the texture is just missing so you run into an invisable wall without warning.
     
    Last edited: Aug 8, 2012
  4. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,499
    Well, if you didn't place an overlay, it isn't an overlay.

    I think once when I had this problem the visualizer was parented rather than associated to the respawn room, or I had named something funny, or both.
     
    • Thanks Thanks x 1
  5. Riever

    Riever L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    Hi,

    Thanks for this. The entity is associated, I've listed the whole window as I must of done something daft...

    Name - blank
    Parent - blank
    Origin - -4616 1540.01 -366
    Render Fx - normal
    Render mode - normal
    Fx Amount - 255
    Fx color 255 255 255
    Disable receiving shadows - no
    global entity name - blank
    Input filter - allow all inputs
    Start diabled - no
    Disable shadows - no
    Assocaited spawn room - blu_respawn
    Solidity - never solid
    Shadows - no
    Solid to Enemies - yes

    The flag Ignore player +USE is ticked.

    None of these enties are showing the texture and changing the texture to something else has no effect. Very odd.
     
  6. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,499
    That looks right, but rereading your post above mine makes me think you didn't actually texture it correctly. Select the brush, make it nodraw. Then with the Face Edit box still open, click on just the front face and change it to the no_entry texture.

    [​IMG]

    As you can see, the rest of the brush is still nodraw.

    [​IMG]

    Sorry if that's what you did, but it doesn't sound like that's what you did.
     
    • Thanks Thanks x 1
    Last edited by a moderator: Aug 8, 2012
  7. henke37

    aa henke37

    Messages:
    1,954
    Positive Ratings:
    465
    Also, check if you messed up with the incredibly unlucky setup where you managed to exactly stretch the transparent part of the texture over the whole face. Yeah, takes skill to screw up that way. And for once I am not speaking from experience.
     
  8. Riever

    Riever L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    Many thanks for the help yyler. I don't know what I did wrong but followed your instructions and got one of the 6 on my map to work. The others still refused to show the texture - despite following the post. So I deleted them and copied the one that works to get all 6 to show the texture. No idea why they didn't 1st time or why I could only get one to work by following your help.