spawnroom problems

Discussion in 'Mapping Questions & Discussion' started by rawrl337, Nov 3, 2009.

  1. rawrl337

    rawrl337 L2: Junior Member

    Messages:
    51
    Positive Ratings:
    0
    i having a lot of difficulty with something thats should be basic and straight forward - spawn rooms. i have read the valve tutorial and a couple other ones but they are all pretty much the same thing (func_respawnroom, etc) but when i compile and test i spawn in the red base no matter what and always in the same spawn location no matter wut, red or blu. any help?

    i made the room, put the func_respawnroom with trigger texture in the room, spawn entities off the ground, and set the spawn entities and respawn room to the appropriate teams

    wut am i doing wrong? :confused::confused::confused:
     
  2. Tapp

    Tapp L10: Glamorous Member

    Messages:
    776
    Positive Ratings:
    211
    Are the func_respawnrooms set to the correct team? If not, just double check absolutely EVERYTHING. You also spawn in the same location every time because that's the first spawn id. Just add in bots and you'll start moving around.
     
  3. Dr. ROCKZO

    Dr. ROCKZO L8: Fancy Shmancy Member

    Messages:
    580
    Positive Ratings:
    159
    It sounds like you only have one info_player_teamspawn. Add more of those (Making sure you set them as either RED or BLU only depending on what you want them to Spawn) and it should work, you're only spawning in the same place each time because there's only one player, if you add bots, they'll spawn at the other info_player_teamspawns.
     
  4. rawrl337

    rawrl337 L2: Junior Member

    Messages:
    51
    Positive Ratings:
    0
    i have 16 of each spawn point and they are set red and blue. i deleted all the red entities and now i only spawn in blue. but when im red it shows me in the red spawn for a split second but then puts me in blue. i dunno why its doing this but if i delete all the blu entities re-make them and set them as blu i always spawn in red.
     
  5. rawrl337

    rawrl337 L2: Junior Member

    Messages:
    51
    Positive Ratings:
    0
    ok. i made the simplest map ever (a hallowed out box) with 2 spawn rooms and made it EXACTLY the same as i did in my real map (although my map is more complex) the simple map works but my real map does not work! can any look at the file and tell me wut is wrong by looking at it and compiling it? (if you do compile turn off RAD otherwise it will take 4 minutes to compile)

    http://www.mediafire.com/?dbycdt1wt24

    to all those who dl it thank you so much
     
  6. UKCS-Alias

    aa UKCS-Alias Mann vs Machine... or... Mapper vs Meta?

    Messages:
    1,264
    Positive Ratings:
    748
    Respawns have 3 settings that control how they work:
    - The basic team value is used when there doesnt exist any round.
    - The CP one will decide who can spawn in it based on the CP. When using that one it will still check the other settings, and only when a team matches both values they can spawn (so if the team was set to red and the cp is owned by blue they cant spawn, when red caps they however get the respawn room)
    - The last values are the respawn for round values. They override the team value based on the round you are in. So the CP check will still work for it.

    I guess in your larger map you used a tcp_round entity which forces you to use the respawn for round values in the respawn entities. And as you didnt set those values, it cant find a respawn entity for you and will fix that by just taking the 1st respawn entity it can find. This couses both red and blue to spawn in 1 place.