Spawnroom Door Problem

Discussion in 'Mapping Questions & Discussion' started by Eight, Sep 23, 2009.

  1. Eight

    Eight L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I am building a spawnroom with 2 exits.

    The first exit worked perfectly fine so then I copied it into the gap for the other exit, renamed the entities so they were unique - edited the inputs and outputs so they all pointed to the correct things and now this exit doesn't work. The door animation is there so it opens and closes but you are not able to pass through the door.

    I am totally out of ideas now - I have tried renaming things again and changed pretty much everything that I can think of that would for some reason mean that this new door wouldn't work - after all it is an exact copy of a working one!

    Any help greatly appreciated :)
     
  2. Caliostro

    Caliostro L6: Sharp Member

    Messages:
    261
    Positive Ratings:
    110
    Most likely culprit is that you missed a target name or entity name. Most likely your real door (not the animation) still has it's old name, so only the animation is being triggered, but the actual door blocking the movement isn't clearing the way.


    Make sure the actual door (not the animation) has the right name (and that it's not the same as the old one), that's getting the right inputs, that the trigger points to it and is giving the right outputs.

    Also make sure it's opening in the right direction. The opening direction isn't automatically adjusted, so if you change the angle, the door still opens in the "old" angle till you change it manually, which can cause some funny glitches.
     
    Last edited: Sep 23, 2009
  3. Eight

    Eight L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    awesome thanks a lot :D after a few tries I found that the move direction was not set correctly so now it is all resolved and working :)

    Case Closed