soundscape question

Discussion in 'Mapping Questions & Discussion' started by tanuki, Aug 28, 2009.

  1. tanuki

    tanuki L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    Okay so my deal is that Ive placed the soundscape and its proxys and its all setup more or less correctly and I hear the sound. The problem is that it takes some time before I do so I was wondering if I can preload them or something. I dont see any flags that would let me do this. So thoughts?
     
  2. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    If a player moves from one soundscape (or no soundscape) to another, it smoothly cross-fades over the course of 3 seconds, IIRC.

    So what you may want to do is make the point where the changeover begins to happen sooner. (It will still take time to do the cross-fading.) Try making a soundscape proxy and placing it further out, like in the doorway to the room instead of in the center of the room.

    If you need a particular sound to be heard quickly, maybe toss an ambient_generic in there.
     
    Last edited: Aug 28, 2009
  3. tanuki

    tanuki L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    sorry I should have been more specific:

    The problem is that I dont hear the soundscape when the map loads. It takes a few seconds like 10+ sometimes.
     
  4. tanuki

    tanuki L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    anyone?
     
  5. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Dunno. Anything in the console?

    There are commands in the console that may help you debug it. One shows the active soundscape(s), and snd_show (IIRC) shows what is currently playing.