sound trigger??

Discussion in 'Mapping Questions & Discussion' started by maxtraxv2, Mar 8, 2009.

  1. maxtraxv2

    maxtraxv2 L3: Member

    Messages:
    103
    Positive Ratings:
    3
    how do i get sound to work with a trigger?

    so it works when you walk over it?
     
  2. Ceiling Man

    Ceiling Man L3: Member

    Messages:
    129
    Positive Ratings:
    17
    I would love to know as well.
     
  3. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    You make an trigger_multiple and an ambient_generic, Set the sound in ambient_generic.
    Go to the I/O of the trigger_multiple and add an output on the ambient_generic to play sound.
     
    • Thanks Thanks x 1
  4. maxtraxv2

    maxtraxv2 L3: Member

    Messages:
    103
    Positive Ratings:
    3
    doesnt work thats why im asking
     
  5. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Ok, Here it is explained a bit better:
    Create an ambient_generic.

    On Name, type anything you will remember, For example: awesomesound.

    Now go to Sound Name and press Browse...
    In this example I used Scout.NeedDispenser01

    Now make a trigger brush where you want it to be able to be played.
    (tools/toolstrigger), Press CTRL-T to bind it to an entity.

    Select trigger_multiple in the drop-down menu on the top.

    Go to outputs, Add... and the following:
    My output named: OnStartTouch
    Target entitys named: the ambient_generic, I used awesomesound.
    Via this output: PlaySound


    Works perfectly for me, If you have a problem hearing it, Increase the volume on the ambient_generic.
     
  6. maxtraxv2

    maxtraxv2 L3: Member

    Messages:
    103
    Positive Ratings:
    3
    ... i know how to do it but PlaySound wont show when i put it in the outputs(as in goes RED) and doesnt function
     
  7. Jive Turkey

    Jive Turkey L3: Member

    Messages:
    120
    Positive Ratings:
    32
    PlaySound wouldn't come up in the Outputs. In Outputs you'd want OnStartTouch, as that Output is what your trigger_multiple is firing. Choose OnStartTouch, then for "Targets entities named" type in the name of your ambient_generic, then for "Via this input" choose PlaySound. I think you're just confusing inputs and outputs, which can seem arbitrary in the beginning. Your target_multiple fires an output, that output goes into the input of another entity, which in the case of your ambient_generic would then "output" a sound.