1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

so my payload map doesn't work

Discussion in 'Mapping Questions & Discussion' started by (-TN-) Ben2, Jun 29, 2009.

  1. (-TN-) Ben2

    (-TN-) Ben2 L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    15
    when i walk up to the cart it heals me but it doesn't move, then when i touch the cart i die,

    i copied the cart from the game entity library and laid a few tracks down that i copied from badwater.

    i numbered the tracks properly but do i have to do anything that tells the payload cart to move or what?
     
  2. pitto

    pitto L3: Member

    Messages:
    109
    Positive Ratings:
    73
    Look at the func_tracktrain properties (the nodraw box that is around the cart model.

    The property first track target should have the name of the first path node

    e.g. plr_red_pathA_start for the red func_tracktrain in the plr race
    Second and third rounds use Teleport to track outputs, so make sure you copy the outputs of the last node from ABS' game type library to your last track_path node
     
  3. (-TN-) Ben2

    (-TN-) Ben2 L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    15
    thank you, mine is single round so i wont need to do that 2nd step but thanks anyways
     
  4. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
    well for the killing part, i know that you have to set it so it doesnt kill people but other things like sentries. You have to set it to a filter. did you forget to copy the enities and all that good stuff?
     
  5. (-TN-) Ben2

    (-TN-) Ben2 L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    15
    yeah i need to copy them entities, well i set it to start on the first track and it still doesn't move, however i will double check my stuff. also it floating above the ground a little bit.
    here is a pic.
     
  6. (-TN-) Ben2

    (-TN-) Ben2 L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    15
    well i copied entities and it still wont move, it dont kill me anymroe, but it wont move
     
  7. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    Make sure your trigger area is large enough. Check to see if your waypoints are high enough off the ground i think 48 units minimum.
     
  8. pitto

    pitto L3: Member

    Messages:
    109
    Positive Ratings:
    73
    It definitely sounds like you haven't copied all the entities.

    The killing when near the train means that you haven't got the filter on the very right of the image (which is setup so that the damage area on the cart only damages buildings), and the not moving means that you haven't got the logic case (on the very left with the blue squares which changes the speed of the train when the number of players near the train changes)
    [​IMG]
    Picture taken from single stage payload, from what I can gather that is what you are making?

    Also I guess this could have been caused if you copied the entities, but then renamed them, but didn't rename outputs and other associated entity attributes
     
  9. (-TN-) Ben2

    (-TN-) Ben2 L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    15
    well the renamed the path tracks thats all i renamed, but i copied everything
     
  10. pitto

    pitto L3: Member

    Messages:
    109
    Positive Ratings:
    73
    I have no idea why it isn't working for you

    What I did when I copied my entities in for my payload race, was drag a selection box around the plr entities and brushes, pressed enter copied them, and pasted them into a new map. Then I compiled straight away to check if they were working properly.

    Now that I knew the entities were working properly I started making the block layout of the map, and once I was ready to layout the track, I just moved the track paths into my main map, and added paths between the start and finish as required.
    (I still have the copied testing area in my map, eventually I will delete it)

    I would suggest doing a process something like this, keep any geometry you have already, but delete the entities from ABS' game type library, and copy the whole single round payload section with the sky box brushes around it, compile and make sure it works, then as with what I did, move the entities over to the main area of the map as you need them
     
  11. (-TN-) Ben2

    (-TN-) Ben2 L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    15
    bring on the fail,

    i recopied the cart and entities and heres what happens


    heres what i did, copied all the entities, copied the cart and everything around it, pasted into my map, i have a few track paths set up, touched the cart, and bammm.... fail tf2 crashed, i changed no settings, why such failure,
     
  12. Open Blade

    Open Blade L7: Fancy Member

    Messages:
    439
    Positive Ratings:
    34
  13. (-TN-) Ben2

    (-TN-) Ben2 L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    15
    well i think i might have it figured out, im gonna build the whole track first then ill test because i tested the abs library thing by itslef and it worked, im gonna build up the rest of the track and try it, ill report back if it is success or fail.