Server crashes on arena map

Discussion in 'Mapping Questions & Discussion' started by Gachl, Mar 18, 2009.

  1. Gachl

    Gachl L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    Hi!
    I've just made a little arena map. Suddenly the server crashes, if a round starts and someone leaves the spawn area. Crash log:
    Code:
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    (SERVER) LoadItems on Account 0 returned FAILCODE of 4 (k_EItemRequestResultInvalid).
    ./srcds_run: line 352: 21262 Segmentation fault      $HL_CMD
    Any ideas what's wrong?

    Thank you!
     
  2. Owlruler

    Owlruler L12: Fabulous Member

    Messages:
    964
    Positive Ratings:
    271
    Could we have a bit more info, like what map, how many players etc.

    EDIT: didn't read your post properly.

    hrmm, are you sure it's when someone leaves the spawn, it may be vecause of a bad output/input but I can't really know since I don't do servers.
     
    Last edited: Mar 18, 2009
  3. drp

    aa drp

    Messages:
    2,251
    Positive Ratings:
    2,551
    the segmentation fault error was supposedly fixed in the last patch.
     
  4. Gachl

    Gachl L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    Ahw, I've just found the problem. I'm using a prop_static with "models/props_farm/doorframe002b.mdl" as World Model as frame for the spawn houses. If I touch it's area the server crashes. I've removed the frame and it works. Anyone knows why?
     
  5. Gachl

    Gachl L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    Segmentation fault is not a specific error.
    Whatever,
    I tested every single possibility why the server is crashing (it's still, even without frames).
    Facts:
    Everything works perfect (arena mode and map and shooting and walking and dying)
    If someone (red or blue team) passes the entrance of the blue spawn the server crashes.
    There is NOTHING (really nothing, absolutely nothing) at that position.
    [​IMG]
    The red line indicates the line a player has to touch to crash the server. In Hammer, the line is white, I've just painted it red to make it more visible.
    As you can see, there is nothing but some brushes all with tf2 textures (no content of other games like hl2). Not a single entity or a invisible wall or something. So why the hack is the server crashing at exactly this position? (I could kill myself, this is so damn impossible!
    thanks!

    EDIT: Okay, this is the most stupid thing I've ever made. There was a func_door. Not used. Empty. And if I touch it the server crashes. *beating myself to death*
    Sorry for bothering you. Problem solved!
     
    Last edited: Mar 18, 2009