Running Teleporter Prop

Discussion in 'Mapping Questions & Discussion' started by Big Lou, Aug 21, 2008.

  1. Big Lou

    Big Lou L3: Member

    Messages:
    120
    Positive Ratings:
    27
    Is there a prop_dynamic engineer teleporter whose animation I can turn on and off with triggers? I want the teleporter similar to cp_falling. Unfortunately you cannot decompile that map.
     
  2. Altaco

    Altaco L7: Fancy Member

    Messages:
    485
    Positive Ratings:
    121
    That's actually not an engi teleporter. I think he put the teleporter prop in the 3d skybox. Just use a trigger_teleport.
     
  3. Big Lou

    Big Lou L3: Member

    Messages:
    120
    Positive Ratings:
    27
    No, I need the actual prop. How do I get it to spin?
     
  4. Altaco

    Altaco L7: Fancy Member

    Messages:
    485
    Positive Ratings:
    121
    You should be able to set the animation sequence. Maybe use a logic_auto with an output to the teleporter prop_dynamic and use the SetAnimation input.
     
  5. VelvetFistIronGlove

    aa VelvetFistIronGlove

    Messages:
    567
    Positive Ratings:
    437
    Just set the "Default animation" keyvalue to "running" in the prop_dynamic's properties. No need for logic entities.

    However, you'll also need to find out the appropriate particle systems, and put them in with info_particle_system entities.
     
    • Thanks Thanks x 1
  6. Frozen Goat

    Frozen Goat L1: Registered

    Messages:
    21
    Positive Ratings:
    0
    Hmmmm

    Well this is the closest thing I've found that answers my question but I have not been able to get it to work.

    I made a prop_dynamic and set it's world model as teleporter.mdl I've named it and assigned it's default animation as "running" without the quotes. I've also tried making sure the "act_obj_running" is highlighted on the actions tab when choosing the world model. I've also tried entering "act_obj_running" as the default. Nothing seems to make the tele spin.

    I have the teleporter working in the sense that it will tele you and make the associated sounds but I would love to have the model actually spinning and have the associated info_particle_system as well.

    Any help I can get in meeting these last two goals for my porters would be greatly appreciated.

    Thanks in advance.
     
  7. GrimGriz

    GrimGriz L10: Glamorous Member

    Messages:
    774
    Positive Ratings:
    133
    trying using the models/buildables/teleporter_light.mdl instead of teleport.mdl, and under the model tab, set the sequence to running
     
    • Thanks Thanks x 3
  8. Frozen Goat

    Frozen Goat L1: Registered

    Messages:
    21
    Positive Ratings:
    0
    THANK YOU!!!! I've spent almost 2 days searching for that answer!! You rock!!!:thumbup:

    Now I just have to get the particle system working above it.
     
  9. maxtraxv2

    maxtraxv2 L3: Member

    Messages:
    103
    Positive Ratings:
    3
    • Thanks Thanks x 2
  10. Frozen Goat

    Frozen Goat L1: Registered

    Messages:
    21
    Positive Ratings:
    0
    Thanks man used the list and now I have fully functional animated teleporters!!! Wo0t!