Resupply Locker Fail... PLZ help

Discussion in 'Mapping Questions & Discussion' started by Nerdsciencegeek, Jun 30, 2011.

  1. Nerdsciencegeek

    Nerdsciencegeek L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I am a relatively new mapper (making my first map actually) and i seem to be having problems with the setup of the resupply lockers. I set up the red and blu lockers exactly the same, with a dynamic model of the locker surrounded by brush entity func_regenerate with no draw textures, but for some reason the red locker is invisible. The func_regenerate is there, but the supply locker is invisible. It appears in the editor, but not in test run. Please help, I would really appreciate it.
     
  2. Hanz

    aa Hanz Ravin' Rabbid

    Messages:
    844
    Positive Ratings:
    474
    The func_regenerate needs a trigger texture.
     
  3. Nerdsciencegeek

    Nerdsciencegeek L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    It's not the func_regenerate that's the problem, it's the locker not rendering. The func_regenerate is still there because it will give you health when you walk near where the locker is supposed to be.
     
  4. StickZer0

    aa StickZer0 💙💙💃💙💙

    Messages:
    664
    Positive Ratings:
    668
  5. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,117
    Positive Ratings:
    6,450
    Check you havent actually set the Render Type to "Don't Render". Also, check the locker isnt somewhere else, i can remember bugs with prop_dynamics moving about by themselves.
     
  6. TheKieranator

    TheKieranator L6: Sharp Member

    Messages:
    282
    Positive Ratings:
    213
    I had this problem once. Never fixed it. I can't remember if I tried very hard though. What happened to me was that the prop_dynamics were at the map origin (x 0 y 0 z 0), and wouldn't go back to where they were supposed to be. How very rude.
     
  7. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,692
    Resupply lockers need to be prop_dynamics in order to show up in-game, and func_regenerates need to have the toolstrigger texture simply because using anything else is silly. If you're having the same problem as kieranator, check your model's origin - that might be broken.
     
  8. Nerdsciencegeek

    Nerdsciencegeek L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I figured out my problem. Apparently i didn't make the resupply locker the func_regenerate's associated model. Thanks alot for all the help.