Ramp brush lighting error

Discussion in 'Mapping Questions & Discussion' started by AntonJ3000, Aug 8, 2009.

  1. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    I've had this problem with mooseshit/koskit since alpha 2/3.
    [​IMG]
    It came when I changed all lightmap scales from 16 to 32.

    So I thought selecting the face and changing it back to 16 would fix problem, but no. It made it even worse.
    [​IMG]

    So I thought, meh, buggy brush, So I remade it from scratch, AND IT'S STILL THERE!!! :cursing:


    Here's how it looks in hammer.
    [​IMG]


    Any idea of how to fix this cursed brush?
     
  2. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Is there another brush under it? Is it prop_detail'ed?
     
  3. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    No to both.
     
  4. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Bump
     
  5. alecom

    alecom L8: Fancy Shmancy Member

    Messages:
    516
    Positive Ratings:
    121
    erm... maybe use an info_null?
    I don't know if it will actually work, or how to use it though :p
     
  6. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Erm, how would that work, It's just a entity that removes itself on map-spawn?
     
  7. Fearlezz

    Fearlezz L10: Glamorous Member

    Messages:
    787
    Positive Ratings:
    242
    I have no idea how the actual brush looks like, just 1 face, mind removing the gray side for now? I suspect that the brush might be to thin
     
  8. alecom

    alecom L8: Fancy Shmancy Member

    Messages:
    516
    Positive Ratings:
    121
    well i was thinking about using the info for pointing a spotlight or something at it but meh, that probably would still not look right?

    did you put the surrounding textures' lightmaps back too?
     
  9. re1wind

    aa re1wind

    Messages:
    644
    Positive Ratings:
    592
    Try setting the brush's texture to defaults?
    x | 0.25 | 0
    y | 0.25 | 0
    [x] World [ ] face
    Lightmap [16]

    Taking a look at the actual lightmap via the perspective window could also give you some hints.

    Delete brush, make it from scratch, set texture x & y translation to zero, world, and don't touch the lightmap.

    If that doesn't work, then delete everything besides the vmf file so your compile starts from scratch. Worth trying at least.

    Hide all lights, place a normal light above your New ramp, use the bounding tool with black texture to restrict your map, compile, and see if that helps.

    Although simply remaking the brush would be the easiest solution, also try applying nodraw to your ramp, and then creating a copied displacement along the nodraw ramp.

    Quite a few things you can try to see what's causing the problem, how you can fix it, etc. Hope that makes sense and helps :)